summaryrefslogtreecommitdiff
path: root/community
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2022-01-13 09:40:06 +0100
committerAndreas Baumann <mail@andreasbaumann.cc>2022-01-13 09:40:06 +0100
commit5b8623bded56a366452ac29242af12b12d2964cf (patch)
tree07fd352f6167585a80f13ce6248fab2c0188135c /community
parent30df5f31e405a335f922bb8bd2d08ca6d129ce21 (diff)
downloadpackages-5b8623bded56a366452ac29242af12b12d2964cf.tar.xz
community/python-debugpy: patch for 32-bit C library
Diffstat (limited to 'community')
-rw-r--r--community/python-debugpy/PKGBUILD11
1 files changed, 11 insertions, 0 deletions
diff --git a/community/python-debugpy/PKGBUILD b/community/python-debugpy/PKGBUILD
new file mode 100644
index 00000000..f3266163
--- /dev/null
+++ b/community/python-debugpy/PKGBUILD
@@ -0,0 +1,11 @@
+# patch 64-bit mode compilation to 32-bit mode (and naming of
+# resulting library)
+# why we would not just ommit the mode and omit the naming in
+# the library is beyond me..
+eval "$(
+ declare -f build | \
+ sed '
+ s/-m64/-m32/g
+ s/attach_linux_amd64.so/attach_linux_i686.so/
+ '
+)"