summaryrefslogtreecommitdiff
path: root/community
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2017-08-26 14:20:17 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2017-08-26 14:20:17 +0200
commit5521dbd7d889b9bdcfc546d3d14f5d810ff9b0a4 (patch)
treef3dfeaa887a514275447c73a3b3d5f60db68144b /community
parenta348aea830eaa7263f17784140c910b0c78c6f42 (diff)
downloadpackages-5521dbd7d889b9bdcfc546d3d14f5d810ff9b0a4.tar.xz
community/cringo: fixed compilation using -latomic patch from upstream
Diffstat (limited to 'community')
-rw-r--r--community/clingo/PKGBUILD21
1 files changed, 8 insertions, 13 deletions
diff --git a/community/clingo/PKGBUILD b/community/clingo/PKGBUILD
index 362b9ad9..707701db 100644
--- a/community/clingo/PKGBUILD
+++ b/community/clingo/PKGBUILD
@@ -1,15 +1,10 @@
-# clang++ misses some C++ atomic stubs in the C++ library on 32-bit,
-# g++ compiles and links fine
-# also reported upstream: https://github.com/potassco/clingo/issues/57
+# see upstream: https://github.com/potassco/clingo/issues/57
-# cmake
-makedepends=(${makedepends[@]/clang})
+arch+=('i686')
+source+=("clang-libatomic.patch::https://github.com/potassco/clasp/commit/fe3e176e2813956000bb947479de2c3d80fe34be.patch")
+sha256sums+=('222b535ffd761c07c3652a3025180bcfb1f1b7504d7353048d5ce485a84c1a27')
-# must be patched after cmake has run, hence it is in build
-eval "$(
- declare -f build | \
- sed '
- s/-DCMAKE_CXX_COMPILER=clang++/-DCMAKE_CXX_COMPILER=g++/
- /^\s*ninja\s*/i sed -i s/clang++/g++/g ${srcdir}/build/rules.ninja
- '
-)"
+prepare() {
+ cd $pkgname-$pkgver/clasp
+ patch -p1 -i ../../clang-libatomic.patch
+}