summaryrefslogtreecommitdiff
path: root/community
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2020-04-23 08:49:58 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2020-04-23 08:49:58 +0200
commit52f188854485489d3107cc54be58d3eb525a757a (patch)
tree17cffca2b7f32b1eb4ba37a8178c053ffd7033aa /community
parent8197de7073a5f932274e1c2636e8cc8e89530c64 (diff)
downloadpackages-52f188854485489d3107cc54be58d3eb525a757a.tar.xz
community/python-shapely: redone the load_dll patch
Diffstat (limited to 'community')
-rw-r--r--community/python-shapely/PKGBUILD2
-rw-r--r--community/python-shapely/load_dll_c.patch42
2 files changed, 12 insertions, 32 deletions
diff --git a/community/python-shapely/PKGBUILD b/community/python-shapely/PKGBUILD
index 6d774d77..14ce07a9 100644
--- a/community/python-shapely/PKGBUILD
+++ b/community/python-shapely/PKGBUILD
@@ -5,7 +5,7 @@
# - https://community.ultimaker.com/topic/29721-archlinux32-cura-341/?_fromLogin=1#replyForm
#
source+=(load_dll_c.patch)
-sha512sums+=('79560d71d2d63d1f173612dec02d1f077a788fb15f5ba3cb64102e62a1e11ec0acc2dc3355b49b154ff90d606ce89e977cbd843af9b81b0dcafc677596f6492e')
+sha512sums+=('6dee4823b76d5057beaed09e9ed529d03a9f76141598a4038f3c51cbca828b1f3e9203a25dab91ee1ff31fee2bf2781d6171dc662f5aa1715c9d5296f8607c60')
eval "$(
declare -f prepare | \
diff --git a/community/python-shapely/load_dll_c.patch b/community/python-shapely/load_dll_c.patch
index ac1c2ec9..8efc8ec5 100644
--- a/community/python-shapely/load_dll_c.patch
+++ b/community/python-shapely/load_dll_c.patch
@@ -1,33 +1,13 @@
-diff -rauN a/shapely/_buildcfg.py b/shapely/_buildcfg.py
---- a/shapely/_buildcfg.py 2018-07-18 22:12:15.000000000 +0200
-+++ b/shapely/_buildcfg.py 2019-10-31 17:08:46.860770741 +0100
-@@ -165,7 +165,7 @@
- if not lgeos:
- lgeos = load_dll('geos_c',
- fallbacks=['libgeos_c.so.1', 'libgeos_c.so'])
-- free = load_dll('c').free
-+ free = load_dll('c', fallbacks=['/usr/lib/libc.so.6']).free
- free.argtypes = [c_void_p]
- free.restype = None
-
-diff -rauN a/shapely/geos.py b/shapely/geos.py
---- a/shapely/geos.py 2018-07-18 22:12:15.000000000 +0200
-+++ b/shapely/geos.py 2019-10-31 17:09:36.292815253 +0100
-@@ -73,7 +73,7 @@
- os.path.join(sys.prefix, "lib", "libgeos_c.so"),
- ]
- _lgeos = load_dll('geos_c', fallbacks=alt_paths)
-- free = load_dll('c').free
-+ free = load_dll('c', fallbacks=['/usr/lib/libc.so.6']).free
- free.argtypes = [c_void_p]
- free.restype = None
-
-@@ -110,7 +110,7 @@
- ]
+diff -rauN Shapely-1.7.0/shapely/geos.py Shapely-1.7.0-load_dll-patch/shapely/geos.py
+--- Shapely-1.7.0/shapely/geos.py 2019-12-31 18:31:44.000000000 +0100
++++ Shapely-1.7.0-load_dll-patch/shapely/geos.py 2020-04-23 08:46:30.677274478 +0200
+@@ -87,7 +87,8 @@
_lgeos = load_dll('geos_c', fallbacks=alt_paths)
-
-- free = load_dll('c').free
-+ free = load_dll('c', fallbacks=['/usr/lib/libc.so.6']).free
+ # Necessary for environments with only libc.musl
+ c_alt_paths = [
+- 'libc.musl-x86_64.so.1'
++ 'libc.musl-x86_64.so.1',
++ 'libc.so.6'
+ ]
+ free = load_dll('c', fallbacks=c_alt_paths).free
free.argtypes = [c_void_p]
- free.restype = None
-