summaryrefslogtreecommitdiff
path: root/community
diff options
context:
space:
mode:
authorErich Eckner <git@eckner.net>2018-11-06 10:08:53 +0100
committerErich Eckner <git@eckner.net>2018-11-06 10:08:53 +0100
commit4da8f8f7633978813e090c0484d3b29179cc164a (patch)
tree2daa4c085d7cccb7fb7312cc45ca1f3aa09e7ac3 /community
parentee417e92f74b5a99d82ed993fbc64f80b418ce87 (diff)
downloadpackages-4da8f8f7633978813e090c0484d3b29179cc164a.tar.xz
community/lbzip2: add hotfix
Diffstat (limited to 'community')
-rw-r--r--community/lbzip2/4af4a4a71827c0bc5e0ec67af23edef4f15cee8e.patch30
-rw-r--r--community/lbzip2/PKGBUILD8
2 files changed, 38 insertions, 0 deletions
diff --git a/community/lbzip2/4af4a4a71827c0bc5e0ec67af23edef4f15cee8e.patch b/community/lbzip2/4af4a4a71827c0bc5e0ec67af23edef4f15cee8e.patch
new file mode 100644
index 00000000..bfcc13b0
--- /dev/null
+++ b/community/lbzip2/4af4a4a71827c0bc5e0ec67af23edef4f15cee8e.patch
@@ -0,0 +1,30 @@
+diff --git a/lib/fseterr.c b/lib/fseterr.c
+index 82649c3ac..adb637256 100644
+--- a/lib/fseterr.c
++++ b/lib/fseterr.c
+@@ -29,7 +29,7 @@ fseterr (FILE *fp)
+ /* Most systems provide FILE as a struct and the necessary bitmask in
+ <stdio.h>, because they need it for implementing getc() and putc() as
+ fast macros. */
+-#if defined _IO_ftrylockfile || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
++#if defined _IO_EOF_SEEN || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
+ fp->_flags |= _IO_ERR_SEEN;
+ #elif defined __sferror || defined __DragonFly__ || defined __ANDROID__
+ /* FreeBSD, NetBSD, OpenBSD, DragonFly, Mac OS X, Cygwin, Minix 3, Android */
+diff --git a/lib/stdio-impl.h b/lib/stdio-impl.h
+index 78d896e9f..05c5752a2 100644
+--- a/lib/stdio-impl.h
++++ b/lib/stdio-impl.h
+@@ -18,6 +18,12 @@
+ the same implementation of stdio extension API, except that some fields
+ have different naming conventions, or their access requires some casts. */
+
++/* Glibc 2.28 made _IO_IN_BACKUP private. For now, work around this
++ problem by defining it ourselves. FIXME: Do not rely on glibc
++ internals. */
++#if !defined _IO_IN_BACKUP && defined _IO_EOF_SEEN
++# define _IO_IN_BACKUP 0x100
++#endif
+
+ /* BSD stdio derived implementations. */
+
diff --git a/community/lbzip2/PKGBUILD b/community/lbzip2/PKGBUILD
new file mode 100644
index 00000000..64f6940f
--- /dev/null
+++ b/community/lbzip2/PKGBUILD
@@ -0,0 +1,8 @@
+# hotfix for FS#60455
+source+=('4af4a4a71827c0bc5e0ec67af23edef4f15cee8e.patch')
+sha512sums+=('9f46ee5008c95008ee937faae79a045a5e5af410ca32434720ae97fa9fb05b49c6f7990a77216d850dcfd6dd72f9f95237eebb7ff32d4c4964982a2352df4963')
+
+prepare() {
+ cd "${srcdir}"/$pkgname-$pkgver
+ patch -p1 -i ../4af4a4a71827c0bc5e0ec67af23edef4f15cee8e.patch
+}