summaryrefslogtreecommitdiff
path: root/community
diff options
context:
space:
mode:
authorErich Eckner <git@eckner.net>2019-01-21 10:09:17 +0100
committerErich Eckner <git@eckner.net>2019-01-21 10:09:17 +0100
commit35350ce1f7aba9843ea7218dee89ae30a1fe3f5e (patch)
tree7e95d77e100fee2080f754ec7e0846a46af5eaf7 /community
parent149f379709d64b238fa46b48a3ef88816f1bc8a1 (diff)
parentd2b638674f3c14e77568c33672da0e13cf0d7cf9 (diff)
downloadpackages-35350ce1f7aba9843ea7218dee89ae30a1fe3f5e.tar.xz
Merge branch 'master' into i486
Diffstat (limited to 'community')
-rw-r--r--community/glfw/PKGBUILD4
-rw-r--r--community/lbzip2/4af4a4a71827c0bc5e0ec67af23edef4f15cee8e.patch30
-rw-r--r--community/lbzip2/PKGBUILD8
-rw-r--r--community/libfaketime/PKGBUILD7
-rw-r--r--community/libfaketime/libfaketime.patch80
-rw-r--r--community/rxvt-unicode/PKGBUILD2
-rw-r--r--community/teamspeak3/PKGBUILD6
7 files changed, 131 insertions, 6 deletions
diff --git a/community/glfw/PKGBUILD b/community/glfw/PKGBUILD
index c1005d82..21fa2996 100644
--- a/community/glfw/PKGBUILD
+++ b/community/glfw/PKGBUILD
@@ -1,11 +1,11 @@
eval "$(
declare -f package_glfw-x11 | \
sed '
- 2 a arch=('"${arch[@]}"')
+ 2 a arch=('"${arch[*]}"')
'
declare -f package_glfw-wayland | \
sed '
- 2 a arch=('"${arch[@]}"')
+ 2 a arch=('"${arch[*]}"')
'
declare -f package_glfw-doc | \
sed '
diff --git a/community/lbzip2/4af4a4a71827c0bc5e0ec67af23edef4f15cee8e.patch b/community/lbzip2/4af4a4a71827c0bc5e0ec67af23edef4f15cee8e.patch
new file mode 100644
index 00000000..bfcc13b0
--- /dev/null
+++ b/community/lbzip2/4af4a4a71827c0bc5e0ec67af23edef4f15cee8e.patch
@@ -0,0 +1,30 @@
+diff --git a/lib/fseterr.c b/lib/fseterr.c
+index 82649c3ac..adb637256 100644
+--- a/lib/fseterr.c
++++ b/lib/fseterr.c
+@@ -29,7 +29,7 @@ fseterr (FILE *fp)
+ /* Most systems provide FILE as a struct and the necessary bitmask in
+ <stdio.h>, because they need it for implementing getc() and putc() as
+ fast macros. */
+-#if defined _IO_ftrylockfile || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
++#if defined _IO_EOF_SEEN || __GNU_LIBRARY__ == 1 /* GNU libc, BeOS, Haiku, Linux libc5 */
+ fp->_flags |= _IO_ERR_SEEN;
+ #elif defined __sferror || defined __DragonFly__ || defined __ANDROID__
+ /* FreeBSD, NetBSD, OpenBSD, DragonFly, Mac OS X, Cygwin, Minix 3, Android */
+diff --git a/lib/stdio-impl.h b/lib/stdio-impl.h
+index 78d896e9f..05c5752a2 100644
+--- a/lib/stdio-impl.h
++++ b/lib/stdio-impl.h
+@@ -18,6 +18,12 @@
+ the same implementation of stdio extension API, except that some fields
+ have different naming conventions, or their access requires some casts. */
+
++/* Glibc 2.28 made _IO_IN_BACKUP private. For now, work around this
++ problem by defining it ourselves. FIXME: Do not rely on glibc
++ internals. */
++#if !defined _IO_IN_BACKUP && defined _IO_EOF_SEEN
++# define _IO_IN_BACKUP 0x100
++#endif
+
+ /* BSD stdio derived implementations. */
+
diff --git a/community/lbzip2/PKGBUILD b/community/lbzip2/PKGBUILD
new file mode 100644
index 00000000..64f6940f
--- /dev/null
+++ b/community/lbzip2/PKGBUILD
@@ -0,0 +1,8 @@
+# hotfix for FS#60455
+source+=('4af4a4a71827c0bc5e0ec67af23edef4f15cee8e.patch')
+sha512sums+=('9f46ee5008c95008ee937faae79a045a5e5af410ca32434720ae97fa9fb05b49c6f7990a77216d850dcfd6dd72f9f95237eebb7ff32d4c4964982a2352df4963')
+
+prepare() {
+ cd "${srcdir}"/$pkgname-$pkgver
+ patch -p1 -i ../4af4a4a71827c0bc5e0ec67af23edef4f15cee8e.patch
+}
diff --git a/community/libfaketime/PKGBUILD b/community/libfaketime/PKGBUILD
new file mode 100644
index 00000000..6073b8fb
--- /dev/null
+++ b/community/libfaketime/PKGBUILD
@@ -0,0 +1,7 @@
+# hotfix for FS#60456
+source+=('libfaketime.patch')
+md5sums+=('cdec9bde3e4093310225cf458059a321')
+prepare() {
+ cd "${pkgname}-${pkgver}"
+ patch -p1 -i ../libfaketime.patch
+}
diff --git a/community/libfaketime/libfaketime.patch b/community/libfaketime/libfaketime.patch
new file mode 100644
index 00000000..085036c4
--- /dev/null
+++ b/community/libfaketime/libfaketime.patch
@@ -0,0 +1,80 @@
+diff --git a/src/faketime.c b/src/faketime.c
+index 138ebbd..037d749 100644
+--- a/src/faketime.c
++++ b/src/faketime.c
+@@ -209,7 +209,7 @@ int main (int argc, char **argv)
+ int shm_fd;
+ sem_t *sem;
+ struct ft_shared_s *ft_shared;
+- char shared_objs[PATH_BUFSIZE];
++ char shared_objs[PATH_BUFSIZE * 2 + 1];
+
+ /*
+ * Casting of getpid() return value to long needed to make GCC on SmartOS
+@@ -286,7 +286,7 @@ int main (int argc, char **argv)
+ exit(EXIT_FAILURE);
+ }
+
+- snprintf(shared_objs, PATH_BUFSIZE, "%s %s", sem_name, shm_name);
++ snprintf(shared_objs, sizeof(shared_objs), "%s %s", sem_name, shm_name);
+ setenv("FAKETIME_SHARED", shared_objs, true);
+ sem_close(sem);
+ }
+diff --git a/src/libfaketime.c b/src/libfaketime.c
+index eb2d01b..0002619 100644
+--- a/src/libfaketime.c
++++ b/src/libfaketime.c
+@@ -1828,7 +1828,8 @@ void ftpl_init(void)
+ if ((tmp_env = getenv("FAKETIME_SPAWN_TARGET")) != NULL)
+ {
+ spawnsupport = true;
+- (void) strncpy(ft_spawn_target, getenv("FAKETIME_SPAWN_TARGET"), 1024);
++ (void) strncpy(ft_spawn_target, getenv("FAKETIME_SPAWN_TARGET"), sizeof(ft_spawn_target) - 1);
++ ft_spawn_target[sizeof(ft_spawn_target) - 1] = 0;
+ if ((tmp_env = getenv("FAKETIME_SPAWN_SECONDS")) != NULL)
+ {
+ ft_spawn_secs = atol(tmp_env);
+@@ -1889,7 +1890,8 @@ void ftpl_init(void)
+ }
+ else
+ {
+- strncpy(user_faked_time_fmt, tmp_env, BUFSIZ);
++ strncpy(user_faked_time_fmt, tmp_env, BUFSIZ - 1);
++ user_faked_time_fmt[BUFSIZ - 1] = 0;
+ }
+
+ if (shared_sem != 0)
+@@ -1960,6 +1962,14 @@ static void remove_trailing_eols(char *line)
+ * =======================================================================
+ */
+
++#ifdef PTHREAD_SINGLETHREADED_TIME
++static void pthread_cleanup_mutex_lock(void *data)
++{
++ pthread_mutex_t *mutex = data;
++ pthread_mutex_unlock(mutex);
++}
++#endif
++
+ int fake_clock_gettime(clockid_t clk_id, struct timespec *tp)
+ {
+ /* variables used for caching, introduced in version 0.6 */
+@@ -1983,7 +1993,7 @@ int fake_clock_gettime(clockid_t clk_id, struct timespec *tp)
+ #ifdef PTHREAD_SINGLETHREADED_TIME
+ static pthread_mutex_t time_mutex=PTHREAD_MUTEX_INITIALIZER;
+ pthread_mutex_lock(&time_mutex);
+- pthread_cleanup_push((void (*)(void *))pthread_mutex_unlock, (void *)&time_mutex);
++ pthread_cleanup_push(pthread_cleanup_mutex_lock, &time_mutex);
+ #endif
+
+ if ((limited_faking &&
+@@ -2078,7 +2088,8 @@ int fake_clock_gettime(clockid_t clk_id, struct timespec *tp)
+
+ if (NULL != (tmp_env = getenv("FAKETIME")))
+ {
+- strncpy(user_faked_time, tmp_env, BUFFERLEN);
++ strncpy(user_faked_time, tmp_env, BUFFERLEN - 1);
++ user_faked_time[BUFFERLEN - 1] = 0;
+ }
+ else
+ {
diff --git a/community/rxvt-unicode/PKGBUILD b/community/rxvt-unicode/PKGBUILD
index 751b25c1..8b9fbe42 100644
--- a/community/rxvt-unicode/PKGBUILD
+++ b/community/rxvt-unicode/PKGBUILD
@@ -1,7 +1,7 @@
eval "$(
declare -f package_rxvt-unicode | \
sed '
- 2 a arch=('"${arch[@]}"')
+ 2 a arch=('"${arch[*]}"')
'
declare -f package_rxvt-unicode-terminfo | \
sed '
diff --git a/community/teamspeak3/PKGBUILD b/community/teamspeak3/PKGBUILD
index fa0e4ca1..850b3335 100644
--- a/community/teamspeak3/PKGBUILD
+++ b/community/teamspeak3/PKGBUILD
@@ -1,7 +1,7 @@
for ((i=0; i<${#source[@]}; i++)); do
- if [ "${source[${i}]}" = "http://teamspeak.gameserver.gamed.de/ts3/releases/${pkgver}/TeamSpeak3-Client-linux_amd64-${pkgver}.run" ]; then
- source[${i}]="http://teamspeak.gameserver.gamed.de/ts3/releases/${pkgver}/TeamSpeak3-Client-linux_x86-${pkgver}.run"
- sha512sums[${i}]='761210985b0c2f6674ae7da5bceb57783f7bba0827799fd291e951716ac7490aa3ee88d4030b985b67d5397353b459bceef42e6b41467513440ffeeaaa265d54'
+ if [ "${source[${i}]}" = "http://dl.4players.de/ts/releases/${pkgver}/TeamSpeak3-Client-linux_amd64-${pkgver}.run" ]; then
+ source[${i}]="http://dl.4players.de/ts/releases/${pkgver}/TeamSpeak3-Client-linux_x86-${pkgver}.run"
+ sha512sums[${i}]='ad6ea2d5f8237585859c5deac11e0f0b6af6018b2a92fe0aab2a04cfdeab0bd57166bf4fec273d48fedd20819203cba2fd58c3a76b59ec3224e867fc10172808'
fi
done