summaryrefslogtreecommitdiff
path: root/community
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2021-04-12 19:21:09 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2021-04-12 19:21:09 +0200
commit295f6b35ca2b39c23712b123fadcc915998b8885 (patch)
treec3fc3896071afd72ab18eae9123b761168b9acf6 /community
parentce3668047c8ab15ba759896486dc43e6de25722f (diff)
downloadpackages-295f6b35ca2b39c23712b123fadcc915998b8885.tar.xz
community/libavif: ignore rav1e coded on i486 for now (needs Rust)
Diffstat (limited to 'community')
-rw-r--r--community/libavif/PKGBUILD12
1 files changed, 12 insertions, 0 deletions
diff --git a/community/libavif/PKGBUILD b/community/libavif/PKGBUILD
index 21f0f5ad..10c53c42 100644
--- a/community/libavif/PKGBUILD
+++ b/community/libavif/PKGBUILD
@@ -6,3 +6,15 @@ eval "$(
s/-DAVIF_CODEC_SVT=ON/-DAVIF_CODEC_SVT=OFF/
'
)"
+
+# on i486 we ignore rav1e for now (needs rust)
+if [ "$CARCH" = 'i486' ]; then
+ depends=(${depends[@]//rav1e/})
+ eval "$(
+ declare -f build | \
+ sed '
+ s/-DAVIF_CODEC_RAV1E=ON/-DAVIF_CODEC_RAV1E=OFF/
+ '
+ )"
+fi
+