summaryrefslogtreecommitdiff
path: root/community
diff options
context:
space:
mode:
authorErich Eckner <git@eckner.net>2019-01-21 10:08:05 +0100
committerErich Eckner <git@eckner.net>2019-01-21 10:08:05 +0100
commit149f379709d64b238fa46b48a3ef88816f1bc8a1 (patch)
treee242c726fc402d0ba90f4930fcbeaa3169bda49f /community
parent1897f7c02af5ed11fa4c47c1a8de9f214dbdbd8c (diff)
parentc980d934f2ffb085002debe9e4c863b5e5f48934 (diff)
downloadpackages-149f379709d64b238fa46b48a3ef88816f1bc8a1.tar.xz
Merge branch 'master' into i486
Diffstat (limited to 'community')
-rw-r--r--community/dietlibc/PKGBUILD6
-rw-r--r--community/dietlibc/dietlib-i386-socketcall-also-with-pic.patch19
-rw-r--r--community/glfw/PKGBUILD4
-rw-r--r--community/rxvt-unicode/PKGBUILD2
-rw-r--r--community/squid/PKGBUILD13
-rw-r--r--community/v2ray/PKGBUILD3
6 files changed, 19 insertions, 28 deletions
diff --git a/community/dietlibc/PKGBUILD b/community/dietlibc/PKGBUILD
deleted file mode 100644
index 93715837..00000000
--- a/community/dietlibc/PKGBUILD
+++ /dev/null
@@ -1,6 +0,0 @@
-source+=('dietlib-i386-socketcall-also-with-pic.patch')
-sha256sums+=('2fabb9922b8a9d2ceafb8127e2dd8271b01e18ce61d61804cc1be8edd0f0d5e9')
-prepare() {
- cd "$srcdir"/$pkgname-$pkgver
- patch -p1 -i "${srcdir}"/dietlib-i386-socketcall-also-with-pic.patch
-}
diff --git a/community/dietlibc/dietlib-i386-socketcall-also-with-pic.patch b/community/dietlibc/dietlib-i386-socketcall-also-with-pic.patch
deleted file mode 100644
index 5714fab9..00000000
--- a/community/dietlibc/dietlib-i386-socketcall-also-with-pic.patch
+++ /dev/null
@@ -1,19 +0,0 @@
-diff --git a/i386/syscalls.h b/i386/syscalls.h
-index c4c98629..94f9be53 100644
---- a/i386/syscalls.h
-+++ b/i386/syscalls.h
-@@ -368,7 +368,6 @@ sym: \
- .Lend##sym: ; \
- .size sym,.Lend##sym-sym
-
--#ifndef __PIC__
- #define __socketcall(name,NAME) \
- .text; \
- .type name,@function; \
-@@ -381,6 +380,3 @@ __libc_##name: ; \
- jmp socketcall; \
- .Lend##name:; \
- .size name,.Lend##name-name
--#else
--#define __socketcall(name,NAME)
--#endif
diff --git a/community/glfw/PKGBUILD b/community/glfw/PKGBUILD
index bb9bc52c..c1005d82 100644
--- a/community/glfw/PKGBUILD
+++ b/community/glfw/PKGBUILD
@@ -1,11 +1,11 @@
eval "$(
declare -f package_glfw-x11 | \
sed '
- 2 a arch=(i486 i686 pentium3 x86_64)
+ 2 a arch=('"${arch[@]}"')
'
declare -f package_glfw-wayland | \
sed '
- 2 a arch=(i486 i686 pentium3 x86_64)
+ 2 a arch=('"${arch[@]}"')
'
declare -f package_glfw-doc | \
sed '
diff --git a/community/rxvt-unicode/PKGBUILD b/community/rxvt-unicode/PKGBUILD
index 96c983d4..751b25c1 100644
--- a/community/rxvt-unicode/PKGBUILD
+++ b/community/rxvt-unicode/PKGBUILD
@@ -1,7 +1,7 @@
eval "$(
declare -f package_rxvt-unicode | \
sed '
- 2 a arch=(i486 i686 pentium3 x86_64)
+ 2 a arch=('"${arch[@]}"')
'
declare -f package_rxvt-unicode-terminfo | \
sed '
diff --git a/community/squid/PKGBUILD b/community/squid/PKGBUILD
new file mode 100644
index 00000000..1a2bcc45
--- /dev/null
+++ b/community/squid/PKGBUILD
@@ -0,0 +1,13 @@
+# testing libatomic for __atomic_load_8 fails in configure.ac, following the idea in
+# https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=830942
+# TODO: report upstream in squid project
+
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ eval "$(
+ declare -f build | \
+ sed '
+ s|make|make LDFLAGS="-Wl,--as-needed -latomic -Wl,--no-as-needed"|g
+ ';
+ )"
+fi
diff --git a/community/v2ray/PKGBUILD b/community/v2ray/PKGBUILD
index 1f0094e3..6d55fcd6 100644
--- a/community/v2ray/PKGBUILD
+++ b/community/v2ray/PKGBUILD
@@ -4,3 +4,6 @@ eval "$(
s@/v2ray-custom-linux-64/@/v2ray-custom-linux-32/@
'
)"
+
+# tests hang or last forever
+unset check