summaryrefslogtreecommitdiff
path: root/community
diff options
context:
space:
mode:
authorErich Eckner <git@eckner.net>2019-10-31 20:01:26 +0100
committerErich Eckner <git@eckner.net>2019-10-31 20:01:26 +0100
commit0dcabd431ba63a4ef575b6e8687d1a88426f7696 (patch)
tree6f9b08e7a4617ebaff17ad1fbb7e1cf3b99b7768 /community
parent86cbf27187352b6049e8b417d4396d486b1aef26 (diff)
downloadpackages-0dcabd431ba63a4ef575b6e8687d1a88426f7696.tar.xz
community/python-shapely:
free = load_dll('c', fallbacks=['libc.so.6']).free und $CARCH -> i686 in check()
Diffstat (limited to 'community')
-rw-r--r--community/python-shapely/PKGBUILD23
-rw-r--r--community/python-shapely/load_dll_c.patch33
2 files changed, 56 insertions, 0 deletions
diff --git a/community/python-shapely/PKGBUILD b/community/python-shapely/PKGBUILD
new file mode 100644
index 00000000..6d774d77
--- /dev/null
+++ b/community/python-shapely/PKGBUILD
@@ -0,0 +1,23 @@
+# temporary fix for:
+# - https://github.com/Toblerity/Shapely/pull/762
+#
+# which caused:
+# - https://community.ultimaker.com/topic/29721-archlinux32-cura-341/?_fromLogin=1#replyForm
+#
+source+=(load_dll_c.patch)
+sha512sums+=('79560d71d2d63d1f173612dec02d1f077a788fb15f5ba3cb64102e62a1e11ec0acc2dc3355b49b154ff90d606ce89e977cbd843af9b81b0dcafc677596f6492e')
+
+eval "$(
+ declare -f prepare | \
+ sed '
+ $ i cd Shapely-$pkgver && patch -p1 -i "$srcdir/load_dll_c.patch"
+ '
+)"
+
+# patch CARCH to always use i686 build directory during testing
+eval "$(
+ declare -f check | \
+ sed '
+ /.*py.test/s/\$CARCH/i686/
+ '
+)"
diff --git a/community/python-shapely/load_dll_c.patch b/community/python-shapely/load_dll_c.patch
new file mode 100644
index 00000000..ac1c2ec9
--- /dev/null
+++ b/community/python-shapely/load_dll_c.patch
@@ -0,0 +1,33 @@
+diff -rauN a/shapely/_buildcfg.py b/shapely/_buildcfg.py
+--- a/shapely/_buildcfg.py 2018-07-18 22:12:15.000000000 +0200
++++ b/shapely/_buildcfg.py 2019-10-31 17:08:46.860770741 +0100
+@@ -165,7 +165,7 @@
+ if not lgeos:
+ lgeos = load_dll('geos_c',
+ fallbacks=['libgeos_c.so.1', 'libgeos_c.so'])
+- free = load_dll('c').free
++ free = load_dll('c', fallbacks=['/usr/lib/libc.so.6']).free
+ free.argtypes = [c_void_p]
+ free.restype = None
+
+diff -rauN a/shapely/geos.py b/shapely/geos.py
+--- a/shapely/geos.py 2018-07-18 22:12:15.000000000 +0200
++++ b/shapely/geos.py 2019-10-31 17:09:36.292815253 +0100
+@@ -73,7 +73,7 @@
+ os.path.join(sys.prefix, "lib", "libgeos_c.so"),
+ ]
+ _lgeos = load_dll('geos_c', fallbacks=alt_paths)
+- free = load_dll('c').free
++ free = load_dll('c', fallbacks=['/usr/lib/libc.so.6']).free
+ free.argtypes = [c_void_p]
+ free.restype = None
+
+@@ -110,7 +110,7 @@
+ ]
+ _lgeos = load_dll('geos_c', fallbacks=alt_paths)
+
+- free = load_dll('c').free
++ free = load_dll('c', fallbacks=['/usr/lib/libc.so.6']).free
+ free.argtypes = [c_void_p]
+ free.restype = None
+