summaryrefslogtreecommitdiff
path: root/community
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2021-05-06 07:10:48 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2021-05-06 07:10:48 +0200
commit025a30f6d20b4d14b6b55f9cd5f004630d7f4400 (patch)
treed9c7c2165f12a49e7b36119b59e21076c3269e44 /community
parent69e9bea640ba218eaed7ec75f992de5925ec3fbd (diff)
downloadpackages-025a30f6d20b4d14b6b55f9cd5f004630d7f4400.tar.xz
community/gdal: added proper SSE configure flags (no autoguessing)
Diffstat (limited to 'community')
-rw-r--r--community/gdal/PKGBUILD18
1 files changed, 18 insertions, 0 deletions
diff --git a/community/gdal/PKGBUILD b/community/gdal/PKGBUILD
index 6aa81b69..f2c3ce89 100644
--- a/community/gdal/PKGBUILD
+++ b/community/gdal/PKGBUILD
@@ -1,3 +1,21 @@
+# enable SSE/SSE2 where appripriate
+if [ "${CARCH}" = "i486" -o "${CARCH}" = "i686" ]; then
+ eval "$(
+ declare -f build | \
+ sed '
+ s|./configure |./configure --with-sse=no --with-sse3-no --with-avx=no |
+ '
+ )"
+fi
+if [ "${CARCH}" = "pentium4" ]; then
+ eval "$(
+ declare -f build | \
+ sed '
+ s|./configure |./configure --with-sse=yes --with-ssse3-no --with-avx=no |
+ '
+ )"
+fi
+
# no mariadb yet on i486
if [ "${CARCH}" = "i486" ]; then
depends=(${depends[@]//mariadb-libs/})