summaryrefslogtreecommitdiff
path: root/community
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2017-12-28 08:57:30 +0100
committerAndreas Baumann <mail@andreasbaumann.cc>2017-12-28 08:57:30 +0100
commit9b976714d25ca4ab6b609b77a1cf2dabdb1d64df (patch)
tree16d03b259b9708ca0a1ddd967cc35a348a81ec2e /community
parent1d68c5759c2bea0fb011de2050c987e56403bae5 (diff)
downloadpackages-9b976714d25ca4ab6b609b77a1cf2dabdb1d64df.tar.xz
community/mongodb: removed dependency on wiredtiger (which is 64-bit only and blacklisted)
Diffstat (limited to 'community')
-rw-r--r--community/mongodb/PKGBUILD11
1 files changed, 11 insertions, 0 deletions
diff --git a/community/mongodb/PKGBUILD b/community/mongodb/PKGBUILD
new file mode 100644
index 00000000..f8c6ceb5
--- /dev/null
+++ b/community/mongodb/PKGBUILD
@@ -0,0 +1,11 @@
+# wiredtiger is 64-bit only and blacklisted, so build mongodb without it
+
+depends=($(
+ printf '%s\n' "${depends[@]}" | \
+ sed '/^wiredtiger/d'
+))
+
+_scons_args=($(
+ printf '%s\n' "${_scons_args[@]}" | \
+ sed 's/--use-system-wiredtiger/--wiredtiger=off/g'
+))