summaryrefslogtreecommitdiff
path: root/community/virtualbox/PKGBUILD
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2021-05-07 14:53:07 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2021-05-07 14:53:07 +0200
commit1a65514b6f2a5d1088dde36d927180bcef33000e (patch)
tree695542eff450c00e389dde6c57f59c53af7da974 /community/virtualbox/PKGBUILD
parent3825733d808067515b9c686fccf94ab08d1f1211 (diff)
downloadpackages-1a65514b6f2a5d1088dde36d927180bcef33000e.tar.xz
community/virtualbox: reverted last commit
Diffstat (limited to 'community/virtualbox/PKGBUILD')
-rw-r--r--community/virtualbox/PKGBUILD17
1 files changed, 16 insertions, 1 deletions
diff --git a/community/virtualbox/PKGBUILD b/community/virtualbox/PKGBUILD
index 90c29c6d..037684be 100644
--- a/community/virtualbox/PKGBUILD
+++ b/community/virtualbox/PKGBUILD
@@ -20,9 +20,24 @@ eval "$(
\@\n\s*kmk @ d
}
s|kmk|kmk -j 1|
- '
+ ' | \
+ sed '
+ \@^\s*\./configure @ {
+ s@--disable-\S\+@@g
+ s@--enable-\S\+@@g
+ s@configure @\0--only-additions --disable-kmods @
+ }
+ ';
)"
+pkgname=(
+ $(
+ printf '%s\n' "${pkgname[@]}" \
+ | grep '^virtualbox-guest-' \
+ | grep -v -- '-nox$'
+ )
+)
+
# let's not use too much memory, gcc tmpfiles can in this
# case also be put on a real /tmp (instead of tmpfs) to reduce
# preasure on the RAM