summaryrefslogtreecommitdiff
path: root/community/subdownloader/PKGBUILD
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2018-05-24 15:50:21 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2018-05-24 15:50:21 +0200
commit7af66ce5d9207f3713d741e8cce402da73ba4fca (patch)
tree812efd92530ad39f82dd70923e470eef1ee0dba8 /community/subdownloader/PKGBUILD
parent584940d2093d70edf51b3a1d6c315d6de4f7c90e (diff)
downloadpackages-7af66ce5d9207f3713d741e8cce402da73ba4fca.tar.xz
community/subdownloader: proper fixing, patching setup.py for running check()
Diffstat (limited to 'community/subdownloader/PKGBUILD')
-rw-r--r--community/subdownloader/PKGBUILD17
1 files changed, 9 insertions, 8 deletions
diff --git a/community/subdownloader/PKGBUILD b/community/subdownloader/PKGBUILD
index 4308c994..d5587d3b 100644
--- a/community/subdownloader/PKGBUILD
+++ b/community/subdownloader/PKGBUILD
@@ -1,10 +1,11 @@
-# Tests download a 64-bit Qt5 Python package from https://files.pythonhosted.org
+# Tests download a 64-bit Qt5 Python package from https://files.pythonhosted.org,
+# we can actually rely on the python-pyqt5 Archlinux package giving us that. :-)
# (see https://github.com/subdownloader/subdownloader/issues/30)
-# => disabling all tests for now
-eval "$(
- declare -f check | \
- sed '
- s/\(python setup.py test\)/#\1/
- '
-)"
+source+=(subdownloader-2.1.0rc4-setup-pyqt5-no-download.patch)
+sha512sums+=('95f12cc3ffa474db00446adfb830935aaa2c626d5e15b78c94c7775ff048ed4871ea55fbc64cea7302007745beaaa02452ab3770ca6a41d9db36deddde0d901a')
+
+prepare( ) {
+ cd $pkgname-$pkgver
+ patch -Np1 < "$srcdir/subdownloader-2.1.0rc4-setup-pyqt5-no-download.patch"
+}