summaryrefslogtreecommitdiff
path: root/community/seamonkey
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2019-08-30 15:19:45 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2019-08-30 15:19:45 +0200
commitb1af1071d3f780bc716f71cdb77e49ef409f4635 (patch)
treebe19a2704bd5eecd845609e262689380265c0bfa /community/seamonkey
parentf03254f0d5027531bb0eade0a6d39291a82ea4f8 (diff)
downloadpackages-b1af1071d3f780bc716f71cdb77e49ef409f4635.tar.xz
community/seamonkey: fix for FS#63605 (string format can be null)
Diffstat (limited to 'community/seamonkey')
-rw-r--r--community/seamonkey/PKGBUILD11
-rw-r--r--community/seamonkey/seamonkey-2.49.4-string-fmt.patch12
2 files changed, 23 insertions, 0 deletions
diff --git a/community/seamonkey/PKGBUILD b/community/seamonkey/PKGBUILD
new file mode 100644
index 00000000..5aadd2bc
--- /dev/null
+++ b/community/seamonkey/PKGBUILD
@@ -0,0 +1,11 @@
+# temporary workaround for FS#63605
+
+# see FS#63605
+source+=('seamonkey-2.49.4-string-fmt.patch')
+sha256sums+=('530471ffc123470c05f51e3f10d6690e161d2b64023983c08f9490b3f704f491')
+eval "$(
+ declare -f prepare | \
+ sed '
+ 3 a patch -p1 -i "$srcdir/seamonkey-2.49.4-string-fmt.patch"
+ '
+)"
diff --git a/community/seamonkey/seamonkey-2.49.4-string-fmt.patch b/community/seamonkey/seamonkey-2.49.4-string-fmt.patch
new file mode 100644
index 00000000..6e0f31eb
--- /dev/null
+++ b/community/seamonkey/seamonkey-2.49.4-string-fmt.patch
@@ -0,0 +1,12 @@
+diff -rauN seamonkey-2.49.4/mozilla/js/xpconnect/src/XPCWrappedNative.cpp seamonkey-2.49.4-string-fmt-patch/mozilla/js/xpconnect/src/XPCWrappedNative.cpp
+--- seamonkey-2.49.4/mozilla/js/xpconnect/src/XPCWrappedNative.cpp 2018-07-12 04:17:10.000000000 +0200
++++ seamonkey-2.49.4-string-fmt-patch/mozilla/js/xpconnect/src/XPCWrappedNative.cpp 2019-08-30 15:05:08.309875223 +0200
+@@ -2219,7 +2219,7 @@
+ "(%s" : (i == count-1) ?
+ ", %s)" : ", %s";
+ name = JS_sprintf_append(name, fmt,
+- array[i]->GetNameString());
++ (array[i]->GetNameString() != NULL) ? array[i]->GetNameString() : "(NULL)");
+ }
+ }
+ }