summaryrefslogtreecommitdiff
path: root/community/python-scipy/PKGBUILD
diff options
context:
space:
mode:
authorErich Eckner <git@eckner.net>2019-01-24 13:34:01 +0100
committerErich Eckner <git@eckner.net>2019-01-24 13:34:17 +0100
commitf9dc5dce64deca7b84343abb758895b2db46c43f (patch)
treeaa19578e19983ebf61fc9661dd0367e8c1ae39a4 /community/python-scipy/PKGBUILD
parenta8f689c3a74f8c322335800b9b1b67c2df5b9333 (diff)
downloadpackages-f9dc5dce64deca7b84343abb758895b2db46c43f.tar.xz
community/python-scipy: do not overwrite upstream prepare()
Diffstat (limited to 'community/python-scipy/PKGBUILD')
-rw-r--r--community/python-scipy/PKGBUILD14
1 files changed, 6 insertions, 8 deletions
diff --git a/community/python-scipy/PKGBUILD b/community/python-scipy/PKGBUILD
index 7791f788..26b3f417 100644
--- a/community/python-scipy/PKGBUILD
+++ b/community/python-scipy/PKGBUILD
@@ -1,10 +1,8 @@
# increase standard relative tolerance of verify_gauss_quad
-prepare() {
- sed -i '
- /def verify_gauss_quad/ {
- N
- s/rtol=[^,]\+,/rtol=2e-15,/
- }
- ' "scipy-${pkgver}/scipy/special/tests/test_orthogonal.py"
-}
+eval "$(
+ declare -f prepare | \
+ sed '
+ 2 a sed -i '"'"'/def verify_gauss_quad/ { N; s/rtol=[^,]\+,/rtol=2e-15,/; } '"'"' "scipy-${pkgver}/scipy/special/tests/test_orthogonal.py"
+ '
+)"