summaryrefslogtreecommitdiff
path: root/community/python-commonmark
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2021-01-27 17:37:03 +0100
committerAndreas Baumann <mail@andreasbaumann.cc>2021-01-27 17:37:03 +0100
commitf59ee8fb593673be3a9c97aac691109e138c917d (patch)
treec66dd8d5c930a44e78a38d5c5de226d63a3fdd0b /community/python-commonmark
parentca914e887977bce7e86ddc5dd6c63eb53c014c60 (diff)
downloadpackages-f59ee8fb593673be3a9c97aac691109e138c917d.tar.xz
community/python-commonmark: fixed complete mess-up in PKGBUILD
Diffstat (limited to 'community/python-commonmark')
-rw-r--r--community/python-commonmark/PKGBUILD43
1 files changed, 0 insertions, 43 deletions
diff --git a/community/python-commonmark/PKGBUILD b/community/python-commonmark/PKGBUILD
index bf73e576..d56ea7ed 100644
--- a/community/python-commonmark/PKGBUILD
+++ b/community/python-commonmark/PKGBUILD
@@ -13,46 +13,3 @@ if [ "${CARCH}" == 'i486' ]; then
makedepends=(${makedepends[@]//python-sphinx/})
makedepends=(${makedepends[@]//python-sphinx_rtd_theme/})
fi
-
-# Don't move lib32 support into rust32-lib, we are on 32-bit in the end
-# and don't draw a symlink to 64-bit libraries (but to 32-bit instead)
-
-pkgname=(
- $(
- printf '%s\n' "${pkgname[@]}" | \
- grep -v '^lib32-rust-libs'
- )
-)
-
-# remove 32-bit stuff (shouldn't that be removed automatically?)
-makedepends=(${makedepends[@]//lib32-gcc-libs/})
-
-eval "$(
- declare -f package_rust | \
- sed '
- /mv.*i686-unknown-linux-gnu.*/d
- /ln /s/x86_64-unknown-linux-gnu/i686-unknown-linux-gnu/g
- '
-)"
-
-eval "$(
- declare -f build | \
- sed '
- /mv.*i686-unknown-linux-gnu.*/d
- /ln /s/x86_64-unknown-linux-gnu/i686-unknown-linux-gnu/g
- '
-)"
-
-# Enable on demand, if your previous rust is broken use previous version
-# from build-support (this is preferable to using rust-bin below, but
-# requires all intermediate versions of rust to be built
-makedepends=(${makedepends[@]//rust/})
-makedepends+=('rust148')
-
-# Enable on demand, if your previous rust is broken use previous version
-# from build-support
-#makedepends=(${makedepends[@]//rust/})
-#makedepends+=('rust-bin')
-
-# rust 1.41 is built against llvm 9.0, so force that in as a make dependency
-#makedepends+=('llvm9-libs')