summaryrefslogtreecommitdiff
path: root/community/nodejs
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2021-04-23 21:10:25 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2021-04-23 21:10:25 +0200
commitee1d8a69ca68b05ee81c234d6b79dc511f823660 (patch)
tree13c6cd1699d09d62793d62a13136475e5cd70b56 /community/nodejs
parent318ea92c9fea1350603b64f4cd3540789aa343d7 (diff)
downloadpackages-ee1d8a69ca68b05ee81c234d6b79dc511f823660.tar.xz
community/nodejs: work around out-of-memory issues when linking
Diffstat (limited to 'community/nodejs')
-rw-r--r--community/nodejs/PKGBUILD10
1 files changed, 10 insertions, 0 deletions
diff --git a/community/nodejs/PKGBUILD b/community/nodejs/PKGBUILD
index 78f686cc..efbf8000 100644
--- a/community/nodejs/PKGBUILD
+++ b/community/nodejs/PKGBUILD
@@ -5,3 +5,13 @@ eval "$(
s|./configure|./configure --dest-cpu ia32|g
'
)"
+
+# linker runs out of memory on 32-bit
+eval "$(
+ declare -f build | \
+ sed '
+ 3 i LDFLAGS+=" -Wl,--no-keep-memory"
+ 3 i CFLAGS+=" -g1"
+ 3 i CXXFLAGS+=" -g1"
+ '
+)"