summaryrefslogtreecommitdiff
path: root/community/linux-tools
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2022-04-30 20:21:16 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2022-04-30 20:21:16 +0200
commitb189d048bd389379b57d4436e9e3d4df3e102f95 (patch)
tree71409adf2e2d314bb629b88ed0983c9663d8eea4 /community/linux-tools
parent377eb35b641fad2312bd494548db99614cd81f23 (diff)
downloadpackages-b189d048bd389379b57d4436e9e3d4df3e102f95.tar.xz
community/linux-tools: disabled archive-server
Diffstat (limited to 'community/linux-tools')
-rw-r--r--community/linux-tools/PKGBUILD116
1 files changed, 58 insertions, 58 deletions
diff --git a/community/linux-tools/PKGBUILD b/community/linux-tools/PKGBUILD
index acbe071a..b29bcfc1 100644
--- a/community/linux-tools/PKGBUILD
+++ b/community/linux-tools/PKGBUILD
@@ -1,60 +1,60 @@
# use our tarballer instead of cloning from git
-for ((i=0; i<${#source[@]}; i++)); do
- infos=$(
- printf '%s\n' "${source[${i}]}" | \
- sed '
- s@^\(\([^:]\+\)::\)\?\(git\|hg\)+\([^#?]\+\)\(?signed\)\?#\(\(tag\|commit\)=[^?]\+\)$@\3 \2 \4 \5 \6@
- t
- s@^\(\([^:]\+\)::\)\?\(git\|hg\)+\([^#?]\+\)#\(\(tag\|commit\)=[^?]\+\)\(?signed\)\?$@\3 \2 \4 \7 \5@
- t
- d
- '
- )
- if [ -n "${infos}" ]; then
- source[${i}]=$(
- type="${infos%% *}"
- infos="${infos#* }"
- if [ -n "${infos%% *}" ]; then
- prefix="${infos%% *}"
- else
- prefix=''
- fi
- infos="${infos#* }"
- repo="${infos%% *}"
- repo64=$(
- printf '%s' "${repo}" | \
- base64 -w0 | \
- sed 's/=/%3D/g'
- )
- infos="${infos#* }"
- if [ "${infos%% *}" = '?signed' ]; then
- key_check=$(
- printf '&valid_keys='
- printf '%s,' "${validpgpkeys[@]}" | \
- sed 's/,$//'
- )
- else
- key_check=''
- fi
- infos="${infos#* }"
- if [ -z "${prefix}" ]; then
- prefix="${repo%.git}"
- prefix="${prefix##*/}"
- fi
- prefix_64=$(
- printf '%s/' "${prefix}" | \
- base64 -w0 | \
- sed 's/=/%3D/g'
- )
+#~ for ((i=0; i<${#source[@]}; i++)); do
+ #~ infos=$(
+ #~ printf '%s\n' "${source[${i}]}" | \
+ #~ sed '
+ #~ s@^\(\([^:]\+\)::\)\?\(git\|hg\)+\([^#?]\+\)\(?signed\)\?#\(\(tag\|commit\)=[^?]\+\)$@\3 \2 \4 \5 \6@
+ #~ t
+ #~ s@^\(\([^:]\+\)::\)\?\(git\|hg\)+\([^#?]\+\)#\(\(tag\|commit\)=[^?]\+\)\(?signed\)\?$@\3 \2 \4 \7 \5@
+ #~ t
+ #~ d
+ #~ '
+ #~ )
+ #~ if [ -n "${infos}" ]; then
+ #~ source[${i}]=$(
+ #~ type="${infos%% *}"
+ #~ infos="${infos#* }"
+ #~ if [ -n "${infos%% *}" ]; then
+ #~ prefix="${infos%% *}"
+ #~ else
+ #~ prefix=''
+ #~ fi
+ #~ infos="${infos#* }"
+ #~ repo="${infos%% *}"
+ #~ repo64=$(
+ #~ printf '%s' "${repo}" | \
+ #~ base64 -w0 | \
+ #~ sed 's/=/%3D/g'
+ #~ )
+ #~ infos="${infos#* }"
+ #~ if [ "${infos%% *}" = '?signed' ]; then
+ #~ key_check=$(
+ #~ printf '&valid_keys='
+ #~ printf '%s,' "${validpgpkeys[@]}" | \
+ #~ sed 's/,$//'
+ #~ )
+ #~ else
+ #~ key_check=''
+ #~ fi
+ #~ infos="${infos#* }"
+ #~ if [ -z "${prefix}" ]; then
+ #~ prefix="${repo%.git}"
+ #~ prefix="${prefix##*/}"
+ #~ fi
+ #~ prefix_64=$(
+ #~ printf '%s/' "${prefix}" | \
+ #~ base64 -w0 | \
+ #~ sed 's/=/%3D/g'
+ #~ )
- printf '%s-%s.tar.gz::https://archive-server.archlinux32.org/?t=%s&p=%s&r=%s%s&%s\n' \
- "${prefix}" \
- "${pkgver}" \
- "${type}" \
- "${prefix_64}" \
- "${repo64}" \
- "${key_check}" \
- "${infos}"
- )
- fi
-done
+ #~ printf '%s-%s.tar.gz::https://archive-server.archlinux32.org/?t=%s&p=%s&r=%s%s&%s\n' \
+ #~ "${prefix}" \
+ #~ "${pkgver}" \
+ #~ "${type}" \
+ #~ "${prefix_64}" \
+ #~ "${repo64}" \
+ #~ "${key_check}" \
+ #~ "${infos}"
+ #~ )
+ #~ fi
+#~ done