summaryrefslogtreecommitdiff
path: root/community/gdal
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2021-05-07 11:03:44 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2021-05-07 11:03:44 +0200
commit2203b8e42977cf43372cf692ca0ab4563d4f5e4b (patch)
treee0279bb1b45c9331c02f26326c22039ca2dc697b /community/gdal
parent4bea33b63eb7e0e94bfaf2a3f54165d434d3adcb (diff)
downloadpackages-2203b8e42977cf43372cf692ca0ab4563d4f5e4b.tar.xz
community/gdal: skip python bindings on i486 (FS32#188)
Diffstat (limited to 'community/gdal')
-rw-r--r--community/gdal/PKGBUILD11
1 files changed, 11 insertions, 0 deletions
diff --git a/community/gdal/PKGBUILD b/community/gdal/PKGBUILD
index e14cdc81..5f6d50d7 100644
--- a/community/gdal/PKGBUILD
+++ b/community/gdal/PKGBUILD
@@ -26,3 +26,14 @@ if [ "${CARCH}" = "i486" ]; then
'
)"
fi
+
+# i486 has a stack smash when building the Python bindings (see FS32#188)
+if [ "${CARCH}" = "i486" ]; then
+ eval "$(
+ declare -f package_python-gdal | \
+ sed '
+ 3 i if false; then
+ $ i fi
+ '
+ )"
+fi