summaryrefslogtreecommitdiff
path: root/community/exa/PKGBUILD
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2021-06-30 18:43:30 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2021-06-30 18:43:30 +0200
commitb02a04bc6caff7c08251092c44cf5483912c7ad1 (patch)
tree001b34a1e27e8bc2a5466e4a279c49f09a3cb588 /community/exa/PKGBUILD
parent2e3a761d188938b1e2d16b9ba9ff1eac908fe346 (diff)
downloadpackages-b02a04bc6caff7c08251092c44cf5483912c7ad1.tar.xz
community/exa: removed local patching, added workarounds for rust and pandoc
Diffstat (limited to 'community/exa/PKGBUILD')
-rw-r--r--community/exa/PKGBUILD27
1 files changed, 15 insertions, 12 deletions
diff --git a/community/exa/PKGBUILD b/community/exa/PKGBUILD
index f0d6c232..81065c10 100644
--- a/community/exa/PKGBUILD
+++ b/community/exa/PKGBUILD
@@ -1,15 +1,18 @@
-# fixed in git upstream
-
-source+=('exa-ascii-deprecated.patch')
-md5sums+=('ce36630a183f5d5be9f1a334bdf8a7cc')
+# rust currenly broken, is based on LLVM 11
+makedepends+=(llvm11)
+# pandoc is mainly broken currently (FS32#180)
+makedepends=(${makedepends[@]//pandoc/})
+eval "$(
+ declare -f build | \
+ sed '
+ s/pandoc/#pandoc/
+ '
+)"
eval "$(
- {
- declare -f prepare || \
- printf 'prepare() {\n}\n'
- } \
- | sed '
- $i cd "$srcdir/$pkgname" \
- patch -Np1 -i ../exa-ascii-deprecated.patch
- '
+ declare -f package | \
+ sed '
+ /exa.1/d
+ /exa_colors.5/d
+ '
)"