summaryrefslogtreecommitdiff
path: root/community/electron
diff options
context:
space:
mode:
authorErich Eckner <git@eckner.net>2018-02-07 22:30:38 +0100
committerErich Eckner <git@eckner.net>2018-02-07 22:30:38 +0100
commitfc3fee4443e5a06be2933b4102f0eb4d43482659 (patch)
tree2dddf580f8c5135cf67df8ac6f2ab7fe872adaa3 /community/electron
parente919b36d8a4394828d08ef8b129404a46a09dd62 (diff)
downloadpackages-fc3fee4443e5a06be2933b4102f0eb4d43482659.tar.xz
community/electron: allow build for i686 (again)
Diffstat (limited to 'community/electron')
-rw-r--r--community/electron/PKGBUILD7
-rw-r--r--community/electron/allow-i686.patch14
2 files changed, 21 insertions, 0 deletions
diff --git a/community/electron/PKGBUILD b/community/electron/PKGBUILD
index fea35930..c1f238b2 100644
--- a/community/electron/PKGBUILD
+++ b/community/electron/PKGBUILD
@@ -1,4 +1,11 @@
+source+=('allow-i686.patch')
+sha256sums+=('c209475c16b506d8d888a54c8564718cf9775f450d1867e19e86a03d99a119be')
+
eval "$(
+ declare -f prepare | \
+ sed '
+ 3 a patch -Np1 -i "${srcdir}"/allow-i686.patch
+ '
declare -f build | \
sed '
\,^\s*script/bootstrap.py , s/py/py --target_arch=ia32/
diff --git a/community/electron/allow-i686.patch b/community/electron/allow-i686.patch
new file mode 100644
index 00000000..154ab9bc
--- /dev/null
+++ b/community/electron/allow-i686.patch
@@ -0,0 +1,14 @@
+--- a/script/update.py
++++ b/script/update.py
+@@ -15,11 +15,6 @@ SOURCE_ROOT = os.path.abspath(os.path.dirname(os.path.dirname(__file__)))
+
+ def main():
+ os.chdir(SOURCE_ROOT)
+-
+- if PLATFORM != 'win32' and platform.architecture()[0] != '64bit':
+- print 'Electron is required to be built on a 64bit machine'
+- return 1
+-
+ update_external_binaries()
+ return update_gyp()
+