summaryrefslogtreecommitdiff
path: root/community/electron2
diff options
context:
space:
mode:
authorErich Eckner <git@eckner.net>2018-12-21 11:46:18 +0100
committerErich Eckner <git@eckner.net>2018-12-21 11:46:18 +0100
commit4d9c73f4367e89020aa242b377b9c2d77ffc7d52 (patch)
tree1c7c1487f75b2defb94495bfc67a739c9e153cff /community/electron2
parent55b4da9f6f7d3b2605aedc390593bd97eef87ae0 (diff)
downloadpackages-4d9c73f4367e89020aa242b377b9c2d77ffc7d52.tar.xz
community/electron2: add fixes from electron
Diffstat (limited to 'community/electron2')
-rw-r--r--community/electron2/PKGBUILD16
-rw-r--r--community/electron2/allow-i686.patch14
2 files changed, 30 insertions, 0 deletions
diff --git a/community/electron2/PKGBUILD b/community/electron2/PKGBUILD
new file mode 100644
index 00000000..4f1a6f90
--- /dev/null
+++ b/community/electron2/PKGBUILD
@@ -0,0 +1,16 @@
+source+=('allow-i686.patch')
+sha512sums+=('bce6716f88c0ed7acc72f90ef62f7c4a28b88e98d7fc8dcb6abf545eb6ab7de11e06191618490ed83e7b38b08489063357682ebb909dc952e21cb6dd7b6ddb38')
+
+eval "$(
+ declare -f prepare | \
+ sed '
+ 3 a patch -Np1 -i "${srcdir}"/allow-i686.patch
+ /^}$/ i \
+ find "${srcdir}" \\( '"-name '*.a' -o -name '*.o'"' \\) -delete
+ '
+ declare -f build | \
+ sed '
+ s,/bootstrap.py ,\0--target_arch=ia32 ,
+ s/-t x64/-t ia32/g
+ '
+)"
diff --git a/community/electron2/allow-i686.patch b/community/electron2/allow-i686.patch
new file mode 100644
index 00000000..154ab9bc
--- /dev/null
+++ b/community/electron2/allow-i686.patch
@@ -0,0 +1,14 @@
+--- a/script/update.py
++++ b/script/update.py
+@@ -15,11 +15,6 @@ SOURCE_ROOT = os.path.abspath(os.path.dirname(os.path.dirname(__file__)))
+
+ def main():
+ os.chdir(SOURCE_ROOT)
+-
+- if PLATFORM != 'win32' and platform.architecture()[0] != '64bit':
+- print 'Electron is required to be built on a 64bit machine'
+- return 1
+-
+ update_external_binaries()
+ return update_gyp()
+