summaryrefslogtreecommitdiff
path: root/community/dietlibc
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2017-08-20 11:32:37 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2017-08-20 11:32:37 +0200
commita84c949e3759598fcd1b4c3dac5dd20a2db5df4b (patch)
tree6d141db880db78fe08aaba9c7c3920cd4b0cfe6e /community/dietlibc
parent38304314bca522dc634bad7d7b7ecfd2a67ee14e (diff)
downloadpackages-a84c949e3759598fcd1b4c3dac5dd20a2db5df4b.tar.xz
community/dietlibc: define socketcall in PIC case too
Diffstat (limited to 'community/dietlibc')
-rw-r--r--community/dietlibc/PKGBUILD6
-rw-r--r--community/dietlibc/dietlib-i386-socketcall-also-with-pic.patch19
2 files changed, 25 insertions, 0 deletions
diff --git a/community/dietlibc/PKGBUILD b/community/dietlibc/PKGBUILD
new file mode 100644
index 00000000..85d12a1d
--- /dev/null
+++ b/community/dietlibc/PKGBUILD
@@ -0,0 +1,6 @@
+source+=("dietlib-i386-socketcall-also-with-pic.patch")
+md5sums+=('cc99f41e0ac6ef641d4a96de9161b997')
+prepare() {
+ cd "$srcdir"/$pkgname-$pkgver
+ patch -p1 -i "${srcdir}"/dietlib-i386-socketcall-also-with-pic.patch
+}
diff --git a/community/dietlibc/dietlib-i386-socketcall-also-with-pic.patch b/community/dietlibc/dietlib-i386-socketcall-also-with-pic.patch
new file mode 100644
index 00000000..5714fab9
--- /dev/null
+++ b/community/dietlibc/dietlib-i386-socketcall-also-with-pic.patch
@@ -0,0 +1,19 @@
+diff --git a/i386/syscalls.h b/i386/syscalls.h
+index c4c98629..94f9be53 100644
+--- a/i386/syscalls.h
++++ b/i386/syscalls.h
+@@ -368,7 +368,6 @@ sym: \
+ .Lend##sym: ; \
+ .size sym,.Lend##sym-sym
+
+-#ifndef __PIC__
+ #define __socketcall(name,NAME) \
+ .text; \
+ .type name,@function; \
+@@ -381,6 +380,3 @@ __libc_##name: ; \
+ jmp socketcall; \
+ .Lend##name:; \
+ .size name,.Lend##name-name
+-#else
+-#define __socketcall(name,NAME)
+-#endif