summaryrefslogtreecommitdiff
path: root/build-support
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2022-01-16 19:28:31 +0100
committerAndreas Baumann <mail@andreasbaumann.cc>2022-01-16 19:28:31 +0100
commitec283181960cf3327ec518b4707a73a724492594 (patch)
tree783bcaf39bc858f47791055806441af0ae3b0453 /build-support
parent7d47d737d3d1b6c0961a08d76a37a2af32b866d2 (diff)
downloadpackages-ec283181960cf3327ec518b4707a73a724492594.tar.xz
core/python: reenable LTO/PDO and testing (kept bootstrapping version in disabled python-no-opt-no-check)
Diffstat (limited to 'build-support')
-rw-r--r--build-support/disabled/python-no-opt-no-check/PKGBUILD65
1 files changed, 65 insertions, 0 deletions
diff --git a/build-support/disabled/python-no-opt-no-check/PKGBUILD b/build-support/disabled/python-no-opt-no-check/PKGBUILD
new file mode 100644
index 00000000..357d41c1
--- /dev/null
+++ b/build-support/disabled/python-no-opt-no-check/PKGBUILD
@@ -0,0 +1,65 @@
+# tests run with -j4 per default effectively killing build slaves,
+# forcing single threaded execution of tests
+
+eval "$(
+ declare -f build | \
+ sed "
+ s/make /make EXTRATESTOPTS='-j 1' /
+ "
+)"
+
+eval "$(
+ declare -f check | \
+ sed "
+ s/ -m test.regrtest/ -m test.regrtest -j1/
+ "
+)"
+
+makedepends=(${makedepends[@]//xorg-server-xvfb/})
+makedepends_i686+=(xorg-server-xvfb)
+makedepends_pentium4=("${makedepends_i686[@]}")
+
+# skip xvfb stuff on i486
+if [ "$CARCH" = 'i486' ]; then
+ eval "$(
+ declare -f build | \
+ sed '
+ /export servernum=99/,/done/d
+ s/.*make/make/
+ '
+ )"
+ eval "$(
+ declare -f check | \
+ sed '
+ /export servernum=99/,/done/d
+ s/xvfb-run -s "-screen 0 1920x1080x16 -ac +extension GLX" -a -n "$servernum"//
+ '
+ )"
+fi
+
+# ignore failing realtime scheduling test as the systemd-nspawn container
+# lacks the SYS_NICE capability (at least, I think so)
+# ERROR: test_sched_rr_get_interval (test.test_posix.PosixTester)
+# Bonus points for finding the option to ignore single tests in test_posix
+# test_gdb currently fails for unknown reasons, also not that important
+# test_socket tests take more than 1.5 hours, so ignoring them
+# Ignore test_cmath test_math test_turtle - they fail due to too low precision
+# on i686 (all of them - really? - actually, I just checket test_cmath)
+eval "$(
+ declare -f check | \
+ sed "
+ /-uall/ s/;\?$/ -x test_posix -x test_gdb -x test_socket -x test_cmath -x test_math -x test_turtle \\|\\| true/g
+ "
+)"
+
+# LTO, PDO takes too long
+eval "$(
+ declare -f build | \
+ sed "
+ s/--with-lto/--without-lto/
+ s/--enable-optimizations/--disable-optimizations/
+ "
+)"
+
+# for now disable testing
+unset check