summaryrefslogtreecommitdiff
path: root/build-support
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2022-01-16 07:32:25 +0100
committerAndreas Baumann <mail@andreasbaumann.cc>2022-01-16 07:32:25 +0100
commit18fe759e29642dabaa2326fce9d167c3d04880c8 (patch)
tree94b2975ed3df711e82209112ebea6061d9023e94 /build-support
parent01a4dd2f8fbf7386de0b1b84152425948dd95fec (diff)
downloadpackages-18fe759e29642dabaa2326fce9d167c3d04880c8.tar.xz
build-support/ghc90-bin: patching corrent LLVM target and fixed dependencies
Diffstat (limited to 'build-support')
-rw-r--r--build-support/ghc90-bin/PKGBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/build-support/ghc90-bin/PKGBUILD b/build-support/ghc90-bin/PKGBUILD
index f78e7009..beb4c2bf 100644
--- a/build-support/ghc90-bin/PKGBUILD
+++ b/build-support/ghc90-bin/PKGBUILD
@@ -12,8 +12,8 @@ pkgdesc='Legacy binary GHC 9.0 installed on /usr/bin/ghc-9.0 (Feb/2021 - Feb/202
arch=('i486' 'i686' 'pentium4')
url='http://www.haskell.org/ghc/'
license=('custom')
-depends=('gcc' 'gmp' 'libffi' 'perl')
-makedepends=( 'perl' 'libxslt' 'docbook-xsl' 'ncurses5-compat-libs')
+depends=('gcc' 'gmp' 'libffi' 'perl' 'ncurses5-compat-libs')
+makedepends=( 'perl' 'libxslt' 'docbook-xsl')
checkdepends=('python2')
install='ghc.install'
options=('staticlibs')
@@ -58,4 +58,8 @@ package() {
install -d ${pkgdir}/usr/share/licenses/ghc-9.0
install -m644 LICENSE ${pkgdir}/usr/share/licenses/ghc-9.0
+
+ # for some reason I end up with the wrong LLVM target on IA-32,
+ # patch it
+ sed -i 's/,("LLVM target", ".*")/,("LLVM target", "i686-unknown-linux")/' ${pkgdir}/usr/lib/ghc-9.0.1/settings
}