summaryrefslogtreecommitdiff
path: root/build-support/disabled/uinit/PKGBUILD
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2021-07-06 17:14:08 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2021-07-06 17:14:08 +0200
commitcf3bfba940f5a1af9358886c18e91d8b207629f1 (patch)
treee2312b7ca62a7515496f44aa01e4b707d2c08619 /build-support/disabled/uinit/PKGBUILD
parente80f4a12a5e313bbc484bc3958c90214749495ec (diff)
downloadpackages-cf3bfba940f5a1af9358886c18e91d8b207629f1.tar.xz
added uinit to build-support, got delete on the AUR
Diffstat (limited to 'build-support/disabled/uinit/PKGBUILD')
-rw-r--r--build-support/disabled/uinit/PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/build-support/disabled/uinit/PKGBUILD b/build-support/disabled/uinit/PKGBUILD
new file mode 100644
index 00000000..2afaf4bb
--- /dev/null
+++ b/build-support/disabled/uinit/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Andreas Baumann <mail@andreasbaumann.cc>
+
+pkgname=uinit
+pkgver=20171230git
+_commit=8c11abef
+pkgrel=1
+pkgdesc="uinit -- smallest init possible"
+arch=('i686' 'x86_64')
+url="https://github.com/shiftypenguin/uinit"
+license=('custom:unlicense')
+makedepends=('git')
+source=("git+https://github.com/shiftypenguin/uinit.git#commit=${_commit}")
+sha512sums=('SKIP')
+
+build() {
+ cd "${srcdir}/${pkgname}"
+
+ make CFLAGS="${CFLAGS}"
+}
+
+package(){
+ cd "${srcdir}/${pkgname}"
+
+ install -d -m0755 ${pkgdir}/{usr/bin,sbin}
+
+ make DESTDIR="${pkgdir}" install
+
+ install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
+
+ mv ${pkgdir}/sbin/* ${pkgdir}/usr/bin/.
+ rmdir ${pkgdir}/sbin
+}