summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorErich Eckner <git@eckner.net>2021-05-26 17:32:38 +0200
committerErich Eckner <git@eckner.net>2021-05-26 17:32:38 +0200
commitf75009ac6d75c5cba0b3226d9a177ed257a17d20 (patch)
treeb2d2c186eea957a1435d68665b1382a7718cb31c
parentd3e2ea5eedcb1d6b084d2613b02a8e26295a2ff8 (diff)
downloadpackages-f75009ac6d75c5cba0b3226d9a177ed257a17d20.tar.xz
core/pacman: well, we fix again ...
-rw-r--r--core/pacman/PKGBUILD2
-rw-r--r--core/pacman/replace-i686-by-pentium4-when-architecture-is-auto.patch8
2 files changed, 5 insertions, 5 deletions
diff --git a/core/pacman/PKGBUILD b/core/pacman/PKGBUILD
index 7bfd4f16..a5b17eae 100644
--- a/core/pacman/PKGBUILD
+++ b/core/pacman/PKGBUILD
@@ -24,7 +24,7 @@ if [ ! "${CARCH}" = "i686" ]; then
fi
source+=('replace-i686-by-pentium4-when-architecture-is-auto.patch')
-sha256sums+=('6851f31d94e504637ee2f1dd20a53c029ae459a5ac6641af0d3fb6adf450d3c8')
+sha256sums+=('6a7906bd28a57cbcff58d856ffefbbb9096a163aaff79913b4fac69d75d0028a')
eval "$(
{
diff --git a/core/pacman/replace-i686-by-pentium4-when-architecture-is-auto.patch b/core/pacman/replace-i686-by-pentium4-when-architecture-is-auto.patch
index 4ec75940..5ad0592e 100644
--- a/core/pacman/replace-i686-by-pentium4-when-architecture-is-auto.patch
+++ b/core/pacman/replace-i686-by-pentium4-when-architecture-is-auto.patch
@@ -1,5 +1,5 @@
diff --git a/src/pacman/conf.c b/src/pacman/conf.c
-index 0f0c2cfb..b05c456d 100644
+index 0f0c2cfb..23744328 100644
--- a/src/pacman/conf.c
+++ b/src/pacman/conf.c
@@ -18,6 +18,7 @@
@@ -17,14 +17,14 @@ index 0f0c2cfb..b05c456d 100644
+ if(strcmp(newarch, "i686") == 0) {
+ unsigned int eax, ebx, ecx, edx;
+ __get_cpuid(1, &eax, &ebx, &ecx, &edx);
-+ if (ecx & bit_SSE2)
++ if (edx & bit_SSE2)
+ newarch = strdup("pentium4");
+ }
free(arch);
arch = newarch;
}
diff --git a/src/pacman/pacman.c b/src/pacman/pacman.c
-index 7e810127..2a50fa4b 100644
+index 7e810127..b5bd2a37 100644
--- a/src/pacman/pacman.c
+++ b/src/pacman/pacman.c
@@ -26,6 +26,7 @@
@@ -45,7 +45,7 @@ index 7e810127..2a50fa4b 100644
+ if(strcmp(machine, "i686") == 0) {
+ int eax, ebx, ecx, edx;
+ __get_cpuid(1, &eax, &ebx, &ecx, &edx);
-+ if (ecx & bit_SSE2) {
++ if (edx & bit_SSE2) {
+ strncpy(machine, "pentium4", sizeof machine);
+ machine[sizeof machine-1] = '\0';
+ }