summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2021-06-06 11:23:29 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2021-06-06 11:23:29 +0200
commitf29b4baf7f43e5e4f6672f802f03efd5a70ad358 (patch)
treebaadaf8641a0716e05ee1b7ce0deb49725c82614
parent06061fc64bf2dab596d39028ae51fe24d7121efc (diff)
downloadpackages-f29b4baf7f43e5e4f6672f802f03efd5a70ad358.tar.xz
community/gcc10: fixed local patching
-rw-r--r--community/gcc10/PKGBUILD37
1 files changed, 4 insertions, 33 deletions
diff --git a/community/gcc10/PKGBUILD b/community/gcc10/PKGBUILD
index b2d6ed81..36851333 100644
--- a/community/gcc10/PKGBUILD
+++ b/community/gcc10/PKGBUILD
@@ -17,24 +17,17 @@ eval "$(
/configure/ s,--with-bugurl=https://bugs\.archlinux\.org/,--with-bugurl=https://bugs.archlinux32.org/,
/configure/ s/;$/ --build=$CHOST;/
'
- declare -f package_gcc-libs | \
+ declare -f package_gcc10-libs | \
sed '
s/\$pkgname-multilib//
s@libsanitizer/{a,l,ub,t}san@libsanitizer/{a,l,ub}san@
/provides=/s/libtsan.so//
\@/usr/lib32/@ d
'
- declare -f package_gcc | \
+ declare -f package_gcc10 | \
sed '
s/"lib32-gcc-libs[^"]*"//g
- s@make.*tsan.*install@#\0@
- '
- declare -f package_gcc-ada | \
- sed '
- \,cd .*/32/libada,{
- N
- d
- }
+ s@make.*tsan.*install.*@#\0@
'
)"
eval "$(
@@ -51,29 +44,7 @@ eval "$(
# i486-specific
-# no ADA
-makedepends=(${makedepends[@]//gcc-ada/})
-makedepends_i686+=('gcc-ada')
-
if [ "${CARCH}" = "i486" ]; then
- package_gcc-ada() {
- touch "$pkgdir/this-is-a-dummy-package"
- }
-
- eval "$(
- declare -f build | \
- sed '
- /enable-languages/ s/,ada//
- '
- )"
-
- eval "$(
- declare -f package_gcc | \
- sed '
- s/,gnat-style,gnat_rm,gnat_ugn//
- '
- )"
-
# building toolchain (gcc): again, lobtool problems
# /usr/lib/gcc/i486-pc-linux-gnu/7.3.0/ld: cannot find -lquadmath
# collect2: error: ld returned 1 exit status
@@ -81,7 +52,7 @@ if [ "${CARCH}" = "i486" ]; then
# make: Leaving directory '/build/gcc/src/gcc-build/i486-pc-linux-gnu/libgfortran'
# => wrong link order: libgfortran requires libquadmath
eval "$(
- declare -f package_gcc-libs | \
+ declare -f package_gcc10-libs | \
sed '
/for lib in / s/libgfortran/libquadmath libgfortran/
'