summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2021-04-23 21:10:25 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2021-04-23 21:10:25 +0200
commitee1d8a69ca68b05ee81c234d6b79dc511f823660 (patch)
tree13c6cd1699d09d62793d62a13136475e5cd70b56
parent318ea92c9fea1350603b64f4cd3540789aa343d7 (diff)
downloadpackages-ee1d8a69ca68b05ee81c234d6b79dc511f823660.tar.xz
community/nodejs: work around out-of-memory issues when linking
-rw-r--r--community/libmysofa/PKGBUILD5
-rw-r--r--community/nodejs/PKGBUILD10
2 files changed, 15 insertions, 0 deletions
diff --git a/community/libmysofa/PKGBUILD b/community/libmysofa/PKGBUILD
index e69de29b..6b978deb 100644
--- a/community/libmysofa/PKGBUILD
+++ b/community/libmysofa/PKGBUILD
@@ -0,0 +1,5 @@
+# no nodejs on i486, used only in tests
+if [ "$CARCH" == 'i486' ]; then
+ checkdepends=(${checkdepends[@]//nodejs/})
+ unset check
+fi
diff --git a/community/nodejs/PKGBUILD b/community/nodejs/PKGBUILD
index 78f686cc..efbf8000 100644
--- a/community/nodejs/PKGBUILD
+++ b/community/nodejs/PKGBUILD
@@ -5,3 +5,13 @@ eval "$(
s|./configure|./configure --dest-cpu ia32|g
'
)"
+
+# linker runs out of memory on 32-bit
+eval "$(
+ declare -f build | \
+ sed '
+ 3 i LDFLAGS+=" -Wl,--no-keep-memory"
+ 3 i CFLAGS+=" -g1"
+ 3 i CXXFLAGS+=" -g1"
+ '
+)"