summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2018-09-29 10:25:20 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2018-09-29 10:25:20 +0200
commited7192fa90ced459e89183b0bbe59e4caaae8270 (patch)
tree01660abaf6be94182e73c53212eae042a36aeefc
parentdf067c44c1a5bcccafd8e08424a66b3535ad9261 (diff)
downloadpackages-ed7192fa90ced459e89183b0bbe59e4caaae8270.tar.xz
core/systemd: fix for FS#60239 (debug option collition with meson)
-rw-r--r--core/systemd/PKGBUILD9
-rw-r--r--core/systemd/meson-rename-Ddebug-to-Ddebug-extra.patch26
2 files changed, 35 insertions, 0 deletions
diff --git a/core/systemd/PKGBUILD b/core/systemd/PKGBUILD
new file mode 100644
index 00000000..02cee487
--- /dev/null
+++ b/core/systemd/PKGBUILD
@@ -0,0 +1,9 @@
+source+=('meson-rename-Ddebug-to-Ddebug-extra.patch')
+sha512sums+=('d310e7ea099bd371eb12fb4f474f1518ddc1013612d6a53c3f5777e6a3509eb58c4b5989d31bb04784be70db5d8ca39bff47414456c3fe322194cd7b341ae70c')
+
+eval "$(
+ declare -f prepare | \
+ sed '
+ /patch.*0001.*/a patch -Np1 -i ../meson-rename-Ddebug-to-Ddebug-extra.patch
+ '
+)"
diff --git a/core/systemd/meson-rename-Ddebug-to-Ddebug-extra.patch b/core/systemd/meson-rename-Ddebug-to-Ddebug-extra.patch
new file mode 100644
index 00000000..12607f2a
--- /dev/null
+++ b/core/systemd/meson-rename-Ddebug-to-Ddebug-extra.patch
@@ -0,0 +1,26 @@
+diff --git a/meson.build b/meson.build
+index 88a470a..1d864e3 100644
+--- a/meson.build
++++ b/meson.build
+@@ -765,7 +765,7 @@ substs.set('DEBUGTTY', get_option('debug-tty'))
+
+ enable_debug_hashmap = false
+ enable_debug_mmap_cache = false
+-foreach name : get_option('debug')
++foreach name : get_option('debug-extra')
+ if name == 'hashmap'
+ enable_debug_hashmap = true
+ elif name == 'mmap-cache'
+diff --git a/meson_options.txt b/meson_options.txt
+index 16c1f2b..dc7951b 100644
+--- a/meson_options.txt
++++ b/meson_options.txt
+@@ -46,7 +46,7 @@ option('debug-shell', type : 'string', value : '/bin/sh',
+ description : 'path to debug shell binary')
+ option('debug-tty', type : 'string', value : '/dev/tty9',
+ description : 'specify the tty device for debug shell')
+-option('debug', type : 'array', choices : ['hashmap', 'mmap-cache'], value : [],
++option('debug-extra', type : 'array', choices : ['hashmap', 'mmap-cache'], value : [],
+ description : 'enable extra debugging')
+ option('memory-accounting-default', type : 'boolean',
+ description : 'enable MemoryAccounting= by default')