summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2018-06-22 17:38:20 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2018-06-22 17:38:20 +0200
commitd97996dd2e800e92e0b1a263462e5642cf5011ed (patch)
treed509512f185d80369030e6319d205f92f1a67ec5
parentff954ca5d7107235ce795425d0dbe15e03ab16e5 (diff)
downloadpackages-d97996dd2e800e92e0b1a263462e5642cf5011ed.tar.xz
community/embree2: increased max ISA to SSE4.2
-rw-r--r--community/embree2/PKGBUILD6
1 files changed, 5 insertions, 1 deletions
diff --git a/community/embree2/PKGBUILD b/community/embree2/PKGBUILD
index 632a2d91..711bf167 100644
--- a/community/embree2/PKGBUILD
+++ b/community/embree2/PKGBUILD
@@ -1,8 +1,12 @@
# avoid breakage in newer CPU ISAs, supporting SSE2 should be enough for
# 32-bit platforms
+# for special use cases (like running Archlinux32 on 64-bit hardware)
+# we can support up to SSE4.2 (everything above is too hard to fix).
+# As Embree chooses the ISA at runtime, this is no problem for machines
+# not having SSE4.2
eval "$(
declare -f build | \
sed '
- /cmake/s/-DEMBREE_MAX_ISA="AVX512SKX"/-DEMBREE_MAX_ISA="SSE2"/
+ /cmake/s/-DEMBREE_MAX_ISA="AVX512SKX"/-DEMBREE_MAX_ISA="SSE4.2"/
'
)"