summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2019-08-09 16:00:12 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2019-08-09 16:00:12 +0200
commitbb5ec79bf38d91a08448fcdbca991a2c005711ce (patch)
treec97fecc7e7db4736a3581e985a6ccc1ef5296ed0
parent42a0039782403aa0cda8619a86eb340f677f452c (diff)
downloadpackages-bb5ec79bf38d91a08448fcdbca991a2c005711ce.tar.xz
build-support: added ffmpeg break-cycle PKGBUILD
-rw-r--r--build-support/extra/ffmpeg/PKGBUILD11
-rw-r--r--community/hq/PKGBUILD7
-rw-r--r--community/hq/hq-ia32.patch12
3 files changed, 11 insertions, 19 deletions
diff --git a/build-support/extra/ffmpeg/PKGBUILD b/build-support/extra/ffmpeg/PKGBUILD
new file mode 100644
index 00000000..16b0db61
--- /dev/null
+++ b/build-support/extra/ffmpeg/PKGBUILD
@@ -0,0 +1,11 @@
+# disable x264/xs265 to break cycles
+depends=(${depends[@]//libx264.so/})
+depends=(${depends[@]//libx265.so/})
+
+eval "$(
+ declare -f build | \
+ sed '
+ s/--enable-libx264/--disable-libx264/
+ s/--enable-libx265/--disable-libx265/
+ '
+)"
diff --git a/community/hq/PKGBUILD b/community/hq/PKGBUILD
deleted file mode 100644
index 4e22d247..00000000
--- a/community/hq/PKGBUILD
+++ /dev/null
@@ -1,7 +0,0 @@
-# see upstream https://github.com/coderobe/hq/pull/1
-source+=('hq-ia32.patch')
-md5sums+=('3cecc7f3b1bbe96f6c3a1609730ba574')
-prepare() {
- cd "${pkgname}"
- patch -Np1 -i ../hq-ia32.patch
-}
diff --git a/community/hq/hq-ia32.patch b/community/hq/hq-ia32.patch
deleted file mode 100644
index 07a924e0..00000000
--- a/community/hq/hq-ia32.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff -rauN hq/main.cpp hq-ia32-patch/main.cpp
---- hq/main.cpp 2018-11-25 17:00:49.731669567 +0100
-+++ hq-ia32-patch/main.cpp 2018-11-25 17:01:32.498826389 +0100
-@@ -51,7 +51,7 @@
- static const string afmt_s = "\033[";
- static const string afmt_e = "m";
- static const vector<char> collapsible = {' ', '\t', '\n', '\r'};
--static const vector<unsigned long> breaking = {
-+static const vector<myhtml_tag_id_t> breaking = {
- MyHTML_TAG_BR,
- MyHTML_TAG_P
- };