summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2018-10-06 18:29:45 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2018-10-06 18:29:45 +0200
commita5644ff5e7d24a86103c6b23b2a9204964456047 (patch)
treeb28fef0dc03d398814e9423eb2320cee2eb03169
parent0af9aedcd977e42e2f2bda7957f9545d938f058d (diff)
downloadpackages-a5644ff5e7d24a86103c6b23b2a9204964456047.tar.xz
core/groff/PKGBUILD: some i486 bootstrap patching
-rw-r--r--core/groff/PKGBUILD14
1 files changed, 14 insertions, 0 deletions
diff --git a/core/groff/PKGBUILD b/core/groff/PKGBUILD
new file mode 100644
index 00000000..010083bb
--- /dev/null
+++ b/core/groff/PKGBUILD
@@ -0,0 +1,14 @@
+# i486-specific
+if [ "${CARCH}" = "i486" ]; then
+ # no optional dependencies
+ makedepends=(${makedepends[@]//psutils/})
+ makedepends=(${makedepends[@]//doxygen/})
+
+ eval "$(
+ declare -f build | \
+ sed '
+ s/configure/configure --disable-xml-docs --disable-doxygen-docs --disable-ducktype-docs/
+ '
+ )"
+fi
+