summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorErich Eckner <git@eckner.net>2018-10-19 14:19:28 +0200
committerErich Eckner <git@eckner.net>2018-10-19 14:19:28 +0200
commita21665f95f5a0173a34cecbbdb489b9bd0d159de (patch)
tree946785b4e8aca3043412b739e298e17ca06e5078
parent7bf36c1e664cc9050ec914fa3c5418c8df05b4d5 (diff)
downloadpackages-a21665f95f5a0173a34cecbbdb489b9bd0d159de.tar.xz
core/linux: i486-config should not set LOCALVERSION - otherwise we end up with an "-ARCH-ARCH" suffix
-rw-r--r--core/linux/PKGBUILD2
-rw-r--r--core/linux/config.i4864
2 files changed, 3 insertions, 3 deletions
diff --git a/core/linux/PKGBUILD b/core/linux/PKGBUILD
index a0447e94..481098cc 100644
--- a/core/linux/PKGBUILD
+++ b/core/linux/PKGBUILD
@@ -6,7 +6,7 @@ source_i486=('config.i486')
for ((i=0; i<${#sha256sums[@]}; i++)); do
if [ "${sha256sums[${i}]}" = '321af63cf7dc8e79531ddd8634eddba19e40a18335e7ce61eedd0ad72fef89a5' ]; then
sha256sums_i686=('421086408df4ab3fab0aac1161c4a82cd6256f0b92b30a44259be4c4f59e0c60')
- sha256sums_i486=('4fd1e49bda5c69ebbfec332e532f2fc83146861bbdde581f62b229c9f54bb336')
+ sha256sums_i486=('2795827c56fddbd0fb7516cfd33fdd672cf75a15c1788b9c34ed4483758b95b5')
fi
done
diff --git a/core/linux/config.i486 b/core/linux/config.i486
index 109bd586..401d5c55 100644
--- a/core/linux/config.i486
+++ b/core/linux/config.i486
@@ -54,8 +54,8 @@ CONFIG_THREAD_INFO_IN_TASK=y
#
CONFIG_INIT_ENV_ARG_LIMIT=32
# CONFIG_COMPILE_TEST is not set
-CONFIG_LOCALVERSION="-ARCH"
-# CONFIG_LOCALVERSION_AUTO is not set
+CONFIG_LOCALVERSION=""
+CONFIG_LOCALVERSION_AUTO=y
CONFIG_HAVE_KERNEL_GZIP=y
CONFIG_HAVE_KERNEL_BZIP2=y
CONFIG_HAVE_KERNEL_LZMA=y