summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2018-08-09 16:36:54 +0000
committerAndreas Baumann <mail@andreasbaumann.cc>2018-08-09 16:36:54 +0000
commit9f07f8e51f08a85c000ed48c7d3e72f38f17c818 (patch)
tree58147c59a34b6b109f375848f7da3b53c87f2bd1
parent1d6d56defd8eba30039571e79dc469ae6d6d9c3d (diff)
parent46f6650d711377fe3fb23dfe3f89c3a0a61941e3 (diff)
downloadpackages-9f07f8e51f08a85c000ed48c7d3e72f38f17c818.tar.xz
Merge branch 'master' into i486
-rw-r--r--extra/python/PKGBUILD17
-rw-r--r--extra/python2/PKGBUILD17
2 files changed, 34 insertions, 0 deletions
diff --git a/extra/python/PKGBUILD b/extra/python/PKGBUILD
index 380fd779..407d9333 100644
--- a/extra/python/PKGBUILD
+++ b/extra/python/PKGBUILD
@@ -1,3 +1,20 @@
+# tests run with -j4 per default effectively killing build slaves,
+# forcing single threaded execution of tests
+
+eval "$(
+ declare -f build | \
+ sed "
+ s/make /make EXTRATESTOPTS='-j 1' /
+ "
+)"
+
+eval "$(
+ declare -f check | \
+ sed "
+ s/ -m test.regrtest/ -m test.regrtest -j1/
+ "
+)"
+
# i486-specific
if [ "${CARCH}" = "i486" ]; then
# remove dependency on most things, we want only a simple interpreter
diff --git a/extra/python2/PKGBUILD b/extra/python2/PKGBUILD
index 65e8d592..8dea0a15 100644
--- a/extra/python2/PKGBUILD
+++ b/extra/python2/PKGBUILD
@@ -14,6 +14,23 @@ eval "$(
'
)"
+# tests run with -j4 per default effectively killing build slaves,
+# forcing single threaded execution of tests
+
+eval "$(
+ declare -f build | \
+ sed "
+ s/make/make EXTRATESTOPTS='-j 1' /
+ "
+)"
+
+eval "$(
+ declare -f check | \
+ sed "
+ s/ -m test.regrtest/ -m test.regrtest -j1/
+ "
+)"
+
# i486-specific
if [ "${CARCH}" = "i486" ]; then
# remove dependency on most things, we want only a simple interpreter