summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorErich Eckner <git@eckner.net>2019-12-20 10:00:41 +0100
committerErich Eckner <git@eckner.net>2019-12-20 10:00:41 +0100
commit9ec33eee75e2b600285161f9bebe8a11836da941 (patch)
treec3efbe6c9122207dc84de39c7b9fd61635e3d78b
parent2ffbb9b896cb16932ac88156fe3b152a5d245eec (diff)
downloadpackages-9ec33eee75e2b600285161f9bebe8a11836da941.tar.xz
community/libffado: builds fine without python-pyqt5 - remove that dependency on i486
-rw-r--r--community/libffado/PKGBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/community/libffado/PKGBUILD b/community/libffado/PKGBUILD
new file mode 100644
index 00000000..c8d846c0
--- /dev/null
+++ b/community/libffado/PKGBUILD
@@ -0,0 +1,32 @@
+# not available on i486 (yet) - configure seems to automatically handle absence
+makedepends_i686=(
+ $(
+ printf '%s\n' "${makedepends[@]}" \
+ | grep -xF 'python-pyqt5'
+ )
+)
+makedepends_pentium4=("${makedepends_i686[@]}")
+makedepends=(
+ $(
+ printf '%s\n' "${makedepends[@]}" \
+ | grep -vxF 'python-pyqt5'
+ )
+)
+_IFS="${IFS}"
+IFS=''
+optdepends_i686=(
+ $(
+ printf '%s\n' "${optdepends[@]}" \
+ | grep '^python-pyqt5: '
+ )
+)
+optdepends_pentium4=(
+ "${optdepends_i686[@]}"
+)
+optdepends=(
+ $(
+ printf '%s\n' "${optdepends[@]}" \
+ | grep -v '^python-pyqt5: '
+ )
+)
+IFS="${_IFS}"