summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorErich Eckner <git@eckner.net>2017-12-05 01:36:16 +0100
committerErich Eckner <git@eckner.net>2017-12-05 01:36:16 +0100
commit92f1485ed94966d7ef48ba164b740cebbbd482b9 (patch)
tree9d06660438dc46dc11e185789dbd5b87dbd72e53
parent5e91e28f0d96376bed78ce98e91b7c4f0683dabb (diff)
downloadpackages-92f1485ed94966d7ef48ba164b740cebbbd482b9.tar.xz
build-support/haskell-tasty-hunit-old new
-rw-r--r--build-support/haskell-tasty-hunit-old/PKGBUILD41
1 files changed, 41 insertions, 0 deletions
diff --git a/build-support/haskell-tasty-hunit-old/PKGBUILD b/build-support/haskell-tasty-hunit-old/PKGBUILD
new file mode 100644
index 00000000..5834dffa
--- /dev/null
+++ b/build-support/haskell-tasty-hunit-old/PKGBUILD
@@ -0,0 +1,41 @@
+# $Id$
+# Maintainer: Felix Yan <felixonmars@archlinux.org>
+# Contributor: Arch Haskell Team <arch-haskell@haskell.org>
+
+_hkgname=tasty-hunit
+pkgname=haskell-tasty-hunit-old
+pkgver=0.9.2
+pkgrel=34
+pkgdesc="HUnit support for the Tasty test framework."
+url="http://documentup.com/feuerbach/tasty"
+license=("MIT")
+arch=('i686' 'x86_64')
+depends=('ghc-libs' "haskell-tasty")
+makedepends=('ghc')
+source=("https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
+sha512sums=('f7af615938d8cb9ec40114fc27f196a8bc9991b0aefca9c5de72bdb6872073b6d771f276472f831b8c583eade3d2d1413aee8f194befa450631bdf3ed50ed439')
+provides=("haskell-tasty-hunit=${pkgver}")
+conflicts=('haskell-tasty-hunit')
+
+build() {
+ cd "${srcdir}/${_hkgname}-${pkgver}"
+
+ runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
+ --prefix=/usr --docdir="/usr/share/doc/${pkgname%-*}" \
+ --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid
+ runhaskell Setup build
+ runhaskell Setup register --gen-script
+ runhaskell Setup unregister --gen-script
+ sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
+ sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
+}
+
+package() {
+ cd "${srcdir}/${_hkgname}-${pkgver}"
+
+ install -D -m744 register.sh "${pkgdir}/usr/share/haskell/register/${pkgname%-*}.sh"
+ install -D -m744 unregister.sh "${pkgdir}/usr/share/haskell/unregister/${pkgname%-*}.sh"
+ runhaskell Setup copy --destdir="${pkgdir}"
+ install -D -m644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname%-*}/LICENSE"
+ rm -f "${pkgdir}/usr/share/doc/${pkgname%-*}/LICENSE"
+}