summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2019-08-23 16:47:30 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2019-08-23 16:47:30 +0200
commit80fb3697219d7550a84134f31aef862f24b07887 (patch)
treeec710dff160ed349db31a1f1972f3e194e727ae7
parente1136d110eedea712e79eb52499c5dbccd5d67de (diff)
downloadpackages-80fb3697219d7550a84134f31aef862f24b07887.tar.xz
extra/gd: disabled testing, enabled SSE math for pentium4
-rw-r--r--extra/gd/PKGBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/extra/gd/PKGBUILD b/extra/gd/PKGBUILD
new file mode 100644
index 00000000..2fcaf6a6
--- /dev/null
+++ b/extra/gd/PKGBUILD
@@ -0,0 +1,25 @@
+# the following tests fail
+# FAIL: gdimagecopyresampled/bug00201
+# FAIL: gdimagegrayscale/basic
+# FAIL: gdimageline/gdimageline_bug5
+# FAIL: gdimagerotate/bug00067
+#
+# at least the critical ones go away with SSE-based math
+# see https://github.com/libgd/libgd/issues/242#issuecomment-228959163
+#
+# we enable this ATM only for pentium4, as it seems it doesn't solve anything
+# for i686
+
+# pentium4-specific
+if [ "${CARCH}" = "pentium4" ]; then
+ eval "$(
+ declare -f build | \
+ sed '
+ /configure/ i \
+ export CFLAGS="$CFLAGS -msse -mfpmath=sse"
+ '
+ )"
+fi
+
+# for all platforms we disable testing for now
+unset check