summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2020-08-01 11:06:01 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2020-08-01 11:06:01 +0200
commit73abb9b7f4a64f99451f181c1fffddf63c3907c2 (patch)
tree3ff7fdff2977436793d352703f7cff3e0ba24352
parent45b6b6d9d76786ea4c87f8c8abdd278ee2f69030 (diff)
downloadpackages-73abb9b7f4a64f99451f181c1fffddf63c3907c2.tar.xz
extra/rust: redone config.toml patch
-rw-r--r--extra/rust/PKGBUILD2
-rw-r--r--extra/rust/config.toml.patch12
2 files changed, 7 insertions, 7 deletions
diff --git a/extra/rust/PKGBUILD b/extra/rust/PKGBUILD
index 35269336..c9ecd6b7 100644
--- a/extra/rust/PKGBUILD
+++ b/extra/rust/PKGBUILD
@@ -6,7 +6,7 @@
# see https://github.com/rust-lang/rust/issues/60294
source+=(config.toml.patch)
-sha256sums+=('42e861ba90335d0e2e666e10b12d9ff85ea1bdb711176fb3c09e92375e193660')
+sha256sums+=('0430e94e8f8c6b4c8154b236dc132fc182e8efd28ce5e7685692cef55e408515')
eval "$(
declare -f prepare | \
diff --git a/extra/rust/config.toml.patch b/extra/rust/config.toml.patch
index 8d0762cd..0f0cfc22 100644
--- a/extra/rust/config.toml.patch
+++ b/extra/rust/config.toml.patch
@@ -1,21 +1,21 @@
diff -rauN a/config.toml b/config.toml
---- a/config.toml 2019-10-20 16:44:31.647900892 +0200
-+++ b/config.toml 2019-10-20 16:44:39.637875348 +0200
+--- a/config.toml 2020-08-01 10:50:30.352304826 +0200
++++ b/config.toml 2020-08-01 10:51:38.355820332 +0200
@@ -2,7 +2,7 @@
link-shared = true
[build]
-target = ["x86_64-unknown-linux-gnu", "i686-unknown-linux-gnu"]
+target = ["i686-unknown-linux-gnu"]
+ tools = ["cargo", "rls", "clippy", "miri", "rustfmt", "analysis", "src"]
cargo = "/usr/bin/cargo"
rustc = "/usr/bin/rustc"
- python = "/usr/bin/python"
-@@ -21,11 +21,11 @@
+@@ -22,11 +22,11 @@
# https://github.com/rust-lang/rust/issues/54872
codegen-units-std = 1
--debuginfo-level = 2
-+debuginfo-level = 0
+-debuginfo-level-std = 2
++debuginfo-level-std = 0
channel = "stable"