summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2021-04-21 19:10:42 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2021-04-21 19:10:42 +0200
commit71ac65aa0feb7e8e58edcddf00f000bf41db29e7 (patch)
tree83bb887b69e185a523367c37dcb691de1d2befb3
parent93d3bde5b16818bb3b66d7b6745d991aca403614 (diff)
downloadpackages-71ac65aa0feb7e8e58edcddf00f000bf41db29e7.tar.xz
remove qt5-sensors from the i486 blacklist
-rw-r--r--blacklist/i486/rust/qt5-sensors1
-rw-r--r--extra/brltty/PKGBUILD20
2 files changed, 20 insertions, 1 deletions
diff --git a/blacklist/i486/rust/qt5-sensors b/blacklist/i486/rust/qt5-sensors
deleted file mode 100644
index a906ebfa..00000000
--- a/blacklist/i486/rust/qt5-sensors
+++ /dev/null
@@ -1 +0,0 @@
-blocked by qt5-base
diff --git a/extra/brltty/PKGBUILD b/extra/brltty/PKGBUILD
new file mode 100644
index 00000000..cf6a11f2
--- /dev/null
+++ b/extra/brltty/PKGBUILD
@@ -0,0 +1,20 @@
+# no java on i486 at the moment
+if [ "$CARCH" = 'i486' ]; then
+ makedepends=(${makedepends[@]//java-environment/})
+fi
+
+# add espeak explicitely on i486
+if [ "$CARCH" = 'i486' ]; then
+ makedepends+=(espeak)
+fi
+
+# no polkit on i486
+if [ "$CARCH" = 'i486' ]; then
+ makedepends=(${makedepends[@]//polkit/})
+ eval "$(
+ declare -f package | \
+ sed '
+ /polkit/d
+ '
+ )"
+fi