summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorErich Eckner <git@eckner.net>2019-07-17 08:57:35 +0200
committerErich Eckner <git@eckner.net>2019-07-17 08:57:35 +0200
commit4a770bdbc7701754599f9362cc9e76d3a4d34eec (patch)
treeadcfcac2b220a7c78a5a28b6ff9df4426fd05da3
parent8434519269c9b4364fa28d24a58a8c23ab40cef0 (diff)
downloadpackages-4a770bdbc7701754599f9362cc9e76d3a4d34eec.tar.xz
extra/linux-zen: new version => new config => new checksum
-rw-r--r--extra/linux-zen/PKGBUILD6
-rw-r--r--extra/linux-zen/config7
2 files changed, 8 insertions, 5 deletions
diff --git a/extra/linux-zen/PKGBUILD b/extra/linux-zen/PKGBUILD
index 02d6cae3..f4764352 100644
--- a/extra/linux-zen/PKGBUILD
+++ b/extra/linux-zen/PKGBUILD
@@ -1,9 +1,9 @@
-# upstream git revision: 20e6bc246c8eeb78eeb8ba22236d20dfbda1d90c
+# upstream git revision: 9364c16791ee88e6d87afc673f967fe41180f22d
# fail if upstream's .config changes
for ((i=0; i<${#sha256sums[@]}; i++)); do
- if [ "${sha256sums[${i}]}" = 'f59d47d8faa4c63cd46de0b4813a07fa094250fe01eaf2593b77a31999619e8a' ]; then
- sha256sums[${i}]='8fb92197b33edd57f2a1206d8501577f9fea59e50b1b356714f4a5f3e9fc68ea'
+ if [ "${sha256sums[${i}]}" = '674663ba8566bf1e3c76a2ab84891e9de9390f9cbd7b34f48f2af253cabbd847' ]; then
+ sha256sums[${i}]='af5c390100f4d3f296a12b80f15ed74bb0d14f8aee9cfc0a4157f222f5408da0'
fi
done
diff --git a/extra/linux-zen/config b/extra/linux-zen/config
index db69a40e..f57dfc80 100644
--- a/extra/linux-zen/config
+++ b/extra/linux-zen/config
@@ -1,6 +1,6 @@
#
# Automatically generated file; DO NOT EDIT.
-# Linux/x86 5.2.0-zen1 Kernel Configuration
+# Linux/x86 5.2.1-zen1 Kernel Configuration
#
#
@@ -9788,7 +9788,10 @@ CONFIG_GCC_PLUGIN_STRUCTLEAK=y
# CONFIG_GCC_PLUGIN_STRUCTLEAK_BYREF is not set
CONFIG_GCC_PLUGIN_STRUCTLEAK_BYREF_ALL=y
# CONFIG_GCC_PLUGIN_STRUCTLEAK_VERBOSE is not set
-# CONFIG_GCC_PLUGIN_STACKLEAK is not set
+CONFIG_GCC_PLUGIN_STACKLEAK=y
+CONFIG_STACKLEAK_TRACK_MIN_SIZE=100
+CONFIG_STACKLEAK_METRICS=y
+CONFIG_STACKLEAK_RUNTIME_DISABLE=y
# end of Memory initialization
# end of Kernel hardening options
# end of Security options