summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2021-05-29 15:22:59 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2021-05-29 15:22:59 +0200
commit434b42dac51e916abbba5a4ecfdca700e5f470cc (patch)
tree88ed7ed909adadbb40865c7250a65388a88987ba
parentf1190d0468fdfb02c09714a1a57a238e6956d73c (diff)
downloadpackages-434b42dac51e916abbba5a4ecfdca700e5f470cc.tar.xz
community/lightdm: using duktape-polkit instead of polkit on i486
-rw-r--r--community/lightdm/PKGBUILD13
1 files changed, 13 insertions, 0 deletions
diff --git a/community/lightdm/PKGBUILD b/community/lightdm/PKGBUILD
new file mode 100644
index 00000000..774930a4
--- /dev/null
+++ b/community/lightdm/PKGBUILD
@@ -0,0 +1,13 @@
+# use polkit-duktape instead of polkit on i486
+if [ "$CARCH" = 'i486' ]; then
+ makedepends=(${makedepends[@]//polkit/})
+ makedepends+=(polkit-duktape)
+ if [ "$CARCH" = 'i486' ]; then
+ eval "$(
+ declare -f package_lightdm | \
+ sed '
+ /depends/s/polkit/polkit-duktape/
+ '
+ )"
+ fi
+fi