summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2018-06-27 10:35:53 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2018-06-27 10:35:53 +0200
commit3a7695dc8c4556693b54deaf40c1373757f30ac9 (patch)
treefe9591fc85d3e91a4a567e573634b9d5ecddd6a5
parent496662bd20d70f8bcecd30735e3219f15d0892f9 (diff)
downloadpackages-3a7695dc8c4556693b54deaf40c1373757f30ac9.tar.xz
community/obs-studio: patched a missing QAction header file
-rw-r--r--community/obs-studio/PKGBUILD9
-rw-r--r--community/obs-studio/obs-studio-21.1.1-missing-qaction.patch11
2 files changed, 20 insertions, 0 deletions
diff --git a/community/obs-studio/PKGBUILD b/community/obs-studio/PKGBUILD
new file mode 100644
index 00000000..67cc156f
--- /dev/null
+++ b/community/obs-studio/PKGBUILD
@@ -0,0 +1,9 @@
+# harmless bug, missing an include for QAction, not seen where I could report this upstream,
+# and I don't understand why this doesn't fail on 64-bit?!
+source+=('obs-studio-21.1.1-missing-qaction.patch')
+md5sums+=('7d0c4cd6e2c3a47595af3961d78f8a4e')
+
+prepare() {
+ cd $pkgname-$pkgver
+ patch -Np1 -i "$srcdir/obs-studio-21.1.1-missing-qaction.patch"
+}
diff --git a/community/obs-studio/obs-studio-21.1.1-missing-qaction.patch b/community/obs-studio/obs-studio-21.1.1-missing-qaction.patch
new file mode 100644
index 00000000..a0deccc5
--- /dev/null
+++ b/community/obs-studio/obs-studio-21.1.1-missing-qaction.patch
@@ -0,0 +1,11 @@
+diff -rauN obs-studio-21.1.1/UI/frontend-plugins/frontend-tools/scripts.cpp obs-studio-21.1.1-missing-qaction-patch/UI/frontend-plugins/frontend-tools/scripts.cpp
+--- obs-studio-21.1.1/UI/frontend-plugins/frontend-tools/scripts.cpp 2018-03-22 03:16:59.000000000 +0100
++++ obs-studio-21.1.1-missing-qaction-patch/UI/frontend-plugins/frontend-tools/scripts.cpp 2018-06-27 10:16:33.907952968 +0200
+@@ -12,6 +12,7 @@
+ #include <QFont>
+ #include <QDialogButtonBox>
+ #include <QResizeEvent>
++#include <QAction>
+
+ #include <obs.hpp>
+ #include <obs-module.h>