summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2018-06-22 20:51:25 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2018-06-22 20:51:25 +0200
commit38f61c4dae0c4ba5b9e24c1e445ecb4a7ad6255e (patch)
tree23a5f309210922aadb3f615f13a7cbfc66bfc418
parentd97996dd2e800e92e0b1a263462e5642cf5011ed (diff)
downloadpackages-38f61c4dae0c4ba5b9e24c1e445ecb4a7ad6255e.tar.xz
community/embree2: back to SSE2 max ISA
-rw-r--r--community/embree2/PKGBUILD6
1 files changed, 1 insertions, 5 deletions
diff --git a/community/embree2/PKGBUILD b/community/embree2/PKGBUILD
index 711bf167..632a2d91 100644
--- a/community/embree2/PKGBUILD
+++ b/community/embree2/PKGBUILD
@@ -1,12 +1,8 @@
# avoid breakage in newer CPU ISAs, supporting SSE2 should be enough for
# 32-bit platforms
-# for special use cases (like running Archlinux32 on 64-bit hardware)
-# we can support up to SSE4.2 (everything above is too hard to fix).
-# As Embree chooses the ISA at runtime, this is no problem for machines
-# not having SSE4.2
eval "$(
declare -f build | \
sed '
- /cmake/s/-DEMBREE_MAX_ISA="AVX512SKX"/-DEMBREE_MAX_ISA="SSE4.2"/
+ /cmake/s/-DEMBREE_MAX_ISA="AVX512SKX"/-DEMBREE_MAX_ISA="SSE2"/
'
)"