summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2022-02-04 07:49:18 +0100
committerAndreas Baumann <mail@andreasbaumann.cc>2022-02-04 07:49:18 +0100
commit33fafeb98e5dfe3a72dd3c96378283c5e06935c3 (patch)
tree5ac1ec01fbc7f8663ffa6351bb95bda6b6f17385
parent01a0132a1f6209640d71ce728d029187fd1644d9 (diff)
downloadpackages-33fafeb98e5dfe3a72dd3c96378283c5e06935c3.tar.xz
extra/ffmpeg4.4: applied all patches from ffmpeg
-rw-r--r--extra/ffmpeg4.4/PKGBUILD78
1 files changed, 78 insertions, 0 deletions
diff --git a/extra/ffmpeg4.4/PKGBUILD b/extra/ffmpeg4.4/PKGBUILD
new file mode 100644
index 00000000..8d7c47cb
--- /dev/null
+++ b/extra/ffmpeg4.4/PKGBUILD
@@ -0,0 +1,78 @@
+# disable LTO (breaks with too few registers in error: 'asm' operand has impossible constraints
+# also disable mfx - libmfx does not compile
+eval "$(
+declare -f build | \
+ sed '
+ s/--enable-lto/--disable-lto/
+ s/--enable-libmfx/--disable-libmfx/
+ '
+)"
+depends=(${depends[@]//libmfx/})
+
+# no vamf for non-pentium4
+if [ "$CARCH" == 'i686' ] || [ "$CARCH" == 'i486' ]; then
+ depends=(${depends[@]//vmaf/})
+
+ eval "$(
+ declare -f prepare | \
+ sed '
+ /vmaf/d
+ '
+ )"
+
+ eval "$(
+ declare -f build | \
+ sed '
+ s/--enable-libvmaf/--disable-libvmaf/
+ '
+ )"
+
+fi
+
+# force picking of a modern libvpx and not libvpx1.3 needed for steam
+makedepends+=('libvpx>=1.8.2')
+
+# no AviSynthPlus on i486 (uses Intel intrinsics and cmake support for
+# disabling it is broken)
+makedepends=(${makedepends[@]//avisynthplus/})
+makedepends_i686+=(avisynthplus)
+makedepends_pentium4=("${makedepends_i686[@]}")
+if [ "$CARCH" == 'i486' ]; then
+ eval "$(
+ declare -f build | \
+ sed '
+ s/--enable-avisynth/--disable-avisynth/
+ '
+ )"
+fi
+
+# no rav1e on i486, no Rust (yet)
+if [ "$CARCH" == 'i486' ]; then
+ depends=(${depends[@]//librav1e.so/})
+ eval "$(
+ declare -f build | \
+ sed '
+ s@--enable-librav1e@--disable-librav1e@
+ '
+ )"
+fi
+
+# svt-av1 is 64-bit only
+depends=(${depends[@]//svt-av1/})
+eval "$(
+ declare -f build | \
+ sed '
+ s@--enable-libsvtav1@--disable-libsvtav1@
+ '
+)"
+
+# -latomic on i486
+if [ "$CARCH" == 'i486' ]; then
+ depends=(${depends[@]//librav1e.so/})
+ eval "$(
+ declare -f build | \
+ sed '
+ s@make[^ ]@make EXTRALIBS-ffmpeg=-latomic EXTRALIBS-ffplay=-latomic EXTRALIBS-ffprobe=-latomic@
+ '
+ )"
+fi