summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2020-08-02 15:13:23 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2020-08-02 15:13:23 +0200
commit28a23a9e45213bfa33fa9a01309e6cc489bbbaa4 (patch)
treede4aa3f6eb9e859bdcf7d9e5f80c30b7d3f7ae9e
parentf5a99c945558e5d95ba722228b4f061b9e9afd91 (diff)
downloadpackages-28a23a9e45213bfa33fa9a01309e6cc489bbbaa4.tar.xz
extra/firefox: repatched for 79.0
-rw-r--r--extra/firefox/PKGBUILD8
-rw-r--r--extra/firefox/avoid-libxul-OOM-python-check.patch23
-rw-r--r--extra/firefox/mozconfig-i686.patch12
-rw-r--r--extra/firefox/mozconfig-pentium4.patch10
-rw-r--r--extra/firefox/rust-static-disable-network-test-on-static-libraries.patch8
5 files changed, 33 insertions, 28 deletions
diff --git a/extra/firefox/PKGBUILD b/extra/firefox/PKGBUILD
index f0482553..cd32ea26 100644
--- a/extra/firefox/PKGBUILD
+++ b/extra/firefox/PKGBUILD
@@ -4,7 +4,7 @@
# set correct compiler and toochain tools
if [ "${CARCH}" = "pentium4" ]; then
source+=('mozconfig-pentium4.patch')
- sha256sums+=('708605f390994587277d8357e8452a71fcbfab97394df9678b1b646539e4ce20')
+ sha256sums+=('dd49547b516936fe372f6f63c94e62dd975021ad97bcf31e98551ecff9890aed')
eval "$(
declare -f prepare | \
sed '
@@ -14,7 +14,7 @@ eval "$(
fi
if [ "${CARCH}" = "i686" ]; then
source+=('mozconfig-i686.patch')
- sha256sums+=('b6688e8872da4651653d898ba832d078e30e901bc6b84df07494905320633f22')
+ sha256sums+=('dd49547b516936fe372f6f63c94e62dd975021ad97bcf31e98551ecff9890aed')
eval "$(
declare -f prepare | \
sed '
@@ -125,7 +125,7 @@ eval "$(
# test failure in rust code (complaining about network functions) when PGO is used,
# see https://bugzilla.mozilla.org/show_bug.cgi?id=1565757
source+=('rust-static-disable-network-test-on-static-libraries.patch')
-sha256sums+=('3a40877475912b53c9cc443feff2ccfef71e8a0f8f45615b7959c28203a1c9a9')
+sha256sums+=('cff239cbeca6fb6171ed4849b6b42173ce6b4fd2f671e1d5dedd1d81795f3da8')
eval "$(
declare -f prepare | \
sed '
@@ -145,7 +145,7 @@ eval "$(
# readelf: Error: Unable to seek to 0x801db328 for section headers
source+=('avoid-libxul-OOM-python-check.patch')
-sha256sums+=('c578c970ba0c06d70950a55f45346f4b8c3749a0da62ae4a9b87bc64d86f50c1')
+sha256sums+=('bf2829f280ef05a608584ce7ec95875e147f315bac9609f5e18052bc03e3c4f9')
eval "$(
declare -f prepare | \
sed '
diff --git a/extra/firefox/avoid-libxul-OOM-python-check.patch b/extra/firefox/avoid-libxul-OOM-python-check.patch
index 4aaf550c..04ce4958 100644
--- a/extra/firefox/avoid-libxul-OOM-python-check.patch
+++ b/extra/firefox/avoid-libxul-OOM-python-check.patch
@@ -1,29 +1,30 @@
---- firefox-77.0.1/config/rules.mk 2020-06-03 03:04:50.000000000 +0200
-+++ firefox-77.0.1-avoid-libxul-OOM-python-check-patch/config/rules.mk 2020-06-04 16:43:06.709092454 +0200
-@@ -474,7 +474,7 @@
+diff -rauN firefox-79.0/config/rules.mk firefox-79.0-avoid-libxul-OOM-python-check-patch/config/rules.mk
+--- firefox-79.0/config/rules.mk 2020-07-21 00:49:36.000000000 +0200
++++ firefox-79.0-avoid-libxul-OOM-python-check-patch/config/rules.mk 2020-08-02 14:04:30.846204786 +0200
+@@ -470,7 +470,7 @@
endif # MSVC with manifest tool
else # !WINNT || GNU_CC
$(call EXPAND_CC_OR_CXX,$@) -o $@ $(COMPUTED_CXX_LDFLAGS) $(PGO_CFLAGS) $($(notdir $@)_OBJS) $(RESFILE) $(WIN32_EXE_LDFLAGS) $(LDFLAGS) $(STATIC_LIBS) $(MOZ_PROGRAM_LDFLAGS) $(SHARED_LIBS) $(OS_LIBS)
-- $(call py3_action,check_binary,--target $@)
-+# $(call py3_action,check_binary,--target $@)
+- $(call py_action,check_binary,--target $@)
++# $(call py_action,check_binary,--target $@)
endif # WINNT && !GNU_CC
ifdef ENABLE_STRIP
-@@ -530,7 +530,7 @@
+@@ -526,7 +526,7 @@
endif # MSVC with manifest tool
else
$(call EXPAND_CC_OR_CXX,$@) $(COMPUTED_CXX_LDFLAGS) $(PGO_CFLAGS) -o $@ $($@_OBJS) $(WIN32_EXE_LDFLAGS) $(LDFLAGS) $(STATIC_LIBS) $(MOZ_PROGRAM_LDFLAGS) $(SHARED_LIBS) $(OS_LIBS)
-- $(call py3_action,check_binary,--target $@)
-+# $(call py3_action,check_binary,--target $@)
+- $(call py_action,check_binary,--target $@)
++# $(call py_action,check_binary,--target $@)
endif # WINNT && !GNU_CC
ifdef ENABLE_STRIP
-@@ -610,7 +610,7 @@
+@@ -606,7 +606,7 @@
$(RM) $@
endif
$(MKSHLIB) $($@_OBJS) $(RESFILE) $(LDFLAGS) $(STATIC_LIBS) $(SHARED_LIBS) $(EXTRA_DSO_LDOPTS) $(MOZ_GLUE_LDFLAGS) $(OS_LIBS)
-- $(call py3_action,check_binary,--target $@)
-+# $(call py3_action,check_binary,--target $@)
+- $(call py_action,check_binary,--target $@)
++# $(call py_action,check_binary,--target $@)
ifeq (_WINNT,$(GNU_CC)_$(OS_ARCH))
ifdef MSMANIFEST_TOOL
diff --git a/extra/firefox/mozconfig-i686.patch b/extra/firefox/mozconfig-i686.patch
index 5230d314..885c51af 100644
--- a/extra/firefox/mozconfig-i686.patch
+++ b/extra/firefox/mozconfig-i686.patch
@@ -1,11 +1,13 @@
diff -rauN a/mozconfig b/mozconfig
---- a/mozconfig 2020-04-04 15:35:35.911990038 +0200
-+++ b/mozconfig 2020-04-04 15:36:04.515324252 +0200
-@@ -4,12 +4,12 @@
- ac_add_options --enable-release
+--- a/mozconfig 2020-08-02 13:46:05.333926656 +0200
++++ b/mozconfig 2020-08-02 14:17:41.724611141 +0200
+@@ -5,13 +5,14 @@
ac_add_options --enable-hardening
ac_add_options --enable-optimize
--ac_add_options --enable-rust-simd
+ ac_add_options --enable-rust-simd
+-ac_add_options --enable-linker=lld
++ac_add_options --enable-linker=bfd
+ ac_add_options --disable-elf-hack
-export CC='clang --target=x86_64-unknown-linux-gnu'
-export CXX='clang++ --target=x86_64-unknown-linux-gnu'
-export AR=llvm-ar
diff --git a/extra/firefox/mozconfig-pentium4.patch b/extra/firefox/mozconfig-pentium4.patch
index b179e883..885c51af 100644
--- a/extra/firefox/mozconfig-pentium4.patch
+++ b/extra/firefox/mozconfig-pentium4.patch
@@ -1,10 +1,13 @@
diff -rauN a/mozconfig b/mozconfig
---- a/mozconfig 2020-04-04 12:27:32.340912278 +0200
-+++ b/mozconfig 2020-04-04 12:28:33.890907786 +0200
-@@ -5,11 +5,12 @@
+--- a/mozconfig 2020-08-02 13:46:05.333926656 +0200
++++ b/mozconfig 2020-08-02 14:17:41.724611141 +0200
+@@ -5,13 +5,14 @@
ac_add_options --enable-hardening
ac_add_options --enable-optimize
ac_add_options --enable-rust-simd
+-ac_add_options --enable-linker=lld
++ac_add_options --enable-linker=bfd
+ ac_add_options --disable-elf-hack
-export CC='clang --target=x86_64-unknown-linux-gnu'
-export CXX='clang++ --target=x86_64-unknown-linux-gnu'
-export AR=llvm-ar
@@ -19,4 +22,3 @@ diff -rauN a/mozconfig b/mozconfig
# Branding
ac_add_options --enable-official-branding
-
diff --git a/extra/firefox/rust-static-disable-network-test-on-static-libraries.patch b/extra/firefox/rust-static-disable-network-test-on-static-libraries.patch
index 2ce3ce16..7bcbde2a 100644
--- a/extra/firefox/rust-static-disable-network-test-on-static-libraries.patch
+++ b/extra/firefox/rust-static-disable-network-test-on-static-libraries.patch
@@ -1,5 +1,5 @@
---- firefox-77.0.1/config/makefiles/rust.mk 2020-06-03 03:04:50.000000000 +0200
-+++ firefox-77.0.1-rust-static-disable-network-test-on-static-libraries-patch/config/makefiles/rust.mk 2020-06-04 16:37:14.534723243 +0200
+--- firefox-79.0/config/makefiles/rust.mk 2020-07-21 00:49:36.000000000 +0200
++++ firefox-79.0-rust-static-disable-network-test-on-static-libraries-patch/config/makefiles/rust.mk 2020-08-02 13:56:36.118444982 +0200
@@ -299,15 +299,15 @@
# the chance of proxy bypasses originating from rust code.
# The check only works when rust code is built with -Clto.
@@ -8,7 +8,7 @@
-ifeq ($(OS_ARCH), Linux)
-ifeq (,$(rustflags_sancov)$(MOZ_ASAN)$(MOZ_TSAN)$(MOZ_UBSAN))
-ifneq (,$(filter -Clto,$(cargo_rustc_flags)))
-- $(call py3_action,check_binary,--target --networking $@)
+- $(call py_action,check_binary,--target --networking $@)
-endif
-endif
-endif
@@ -17,7 +17,7 @@
+#ifeq ($(OS_ARCH), Linux)
+#ifeq (,$(rustflags_sancov)$(MOZ_ASAN)$(MOZ_TSAN)$(MOZ_UBSAN))
+#ifneq (,$(filter -Clto,$(cargo_rustc_flags)))
-+# $(call py3_action,check_binary,--target --networking $@)
++# $(call py_action,check_binary,--target --networking $@)
+#endif
+#endif
+#endif