summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2018-07-08 09:18:53 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2018-07-08 09:18:53 +0200
commit1d508a46807414e560ce70591447c6dba0473d63 (patch)
tree9348505ad4fe64b89ddb84f9326816ed16ba5cf6
parent73e1a9a73343d47599f07900213916deeec251b3 (diff)
downloadpackages-1d508a46807414e560ce70591447c6dba0473d63.tar.xz
extra/firefox, community/firefox-developer-edition: antoher linker switch trial
-rw-r--r--community/firefox-developer-edition/PKGBUILD15
-rw-r--r--extra/firefox/PKGBUILD15
2 files changed, 30 insertions, 0 deletions
diff --git a/community/firefox-developer-edition/PKGBUILD b/community/firefox-developer-edition/PKGBUILD
new file mode 100644
index 00000000..108fd67c
--- /dev/null
+++ b/community/firefox-developer-edition/PKGBUILD
@@ -0,0 +1,15 @@
+# the gold linker simply allocates too much memory via mmap, cannot
+# possibly word for libxul.so on 32-bit
+eval "$(
+ declare -f prepare | \
+ sed '
+ s/ac_add_options --enable-linker=gold/--enable-linker=bfd/g
+ '
+)"
+
+eval "$(
+ declare -f build | \
+ sed '
+ /CPPFLAGS/ a LDFLAGS+="-Wl,--no-keep-memory -fuse=ld=bfd"
+ '
+)"
diff --git a/extra/firefox/PKGBUILD b/extra/firefox/PKGBUILD
new file mode 100644
index 00000000..108fd67c
--- /dev/null
+++ b/extra/firefox/PKGBUILD
@@ -0,0 +1,15 @@
+# the gold linker simply allocates too much memory via mmap, cannot
+# possibly word for libxul.so on 32-bit
+eval "$(
+ declare -f prepare | \
+ sed '
+ s/ac_add_options --enable-linker=gold/--enable-linker=bfd/g
+ '
+)"
+
+eval "$(
+ declare -f build | \
+ sed '
+ /CPPFLAGS/ a LDFLAGS+="-Wl,--no-keep-memory -fuse=ld=bfd"
+ '
+)"