summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorErich Eckner <git@eckner.net>2018-05-08 14:11:53 +0200
committerErich Eckner <git@eckner.net>2018-05-08 14:11:53 +0200
commit0a7f17ea623d4e679fcd66f268841812c0c1497b (patch)
tree25fd19f62ac0e6f7aca7a4372861d7410e84b5ec
parent7551e3e14da6d17da0eeeef0672cde712872581a (diff)
downloadpackages-0a7f17ea623d4e679fcd66f268841812c0c1497b.tar.xz
core/filesystem: use a patch and add checksum
-rw-r--r--core/filesystem/PKGBUILD6
-rw-r--r--core/filesystem/os-release8
-rw-r--r--core/filesystem/os-release.patch18
3 files changed, 24 insertions, 8 deletions
diff --git a/core/filesystem/PKGBUILD b/core/filesystem/PKGBUILD
index e69de29b..0cf13c7c 100644
--- a/core/filesystem/PKGBUILD
+++ b/core/filesystem/PKGBUILD
@@ -0,0 +1,6 @@
+source+=('os-release.patch')
+md5sums+=('6ec952a2bbb95ea3d73e0afcf5703c49')
+
+prepare() {
+ patch -p1 -i "$srcdir/os-release.patch"
+}
diff --git a/core/filesystem/os-release b/core/filesystem/os-release
deleted file mode 100644
index 89854294..00000000
--- a/core/filesystem/os-release
+++ /dev/null
@@ -1,8 +0,0 @@
-NAME="Arch Linux 32"
-PRETTY_NAME="Arch Linux 32"
-ID=arch32
-ID_LIKE="arch archlinux"
-ANSI_COLOR="0;36"
-HOME_URL="https://www.archlinux32.org/"
-SUPPORT_URL="https://bbs.archlinux32.org/"
-BUG_REPORT_URL="https://bugs.archlinux32.org/"
diff --git a/core/filesystem/os-release.patch b/core/filesystem/os-release.patch
new file mode 100644
index 00000000..e7372c98
--- /dev/null
+++ b/core/filesystem/os-release.patch
@@ -0,0 +1,18 @@
+--- a/os-release 2018-01-05 20:17:15.000000000 +0100
++++ b/os-release 2018-05-08 13:53:44.625827911 +0200
+@@ -1,8 +1,8 @@
+-NAME="Arch Linux"
+-PRETTY_NAME="Arch Linux"
+-ID=arch
+-ID_LIKE=archlinux
++NAME="Arch Linux 32"
++PRETTY_NAME="Arch Linux 32"
++ID=arch32
++ID_LIKE="arch archlinux"
+ ANSI_COLOR="0;36"
+-HOME_URL="https://www.archlinux.org/"
+-SUPPORT_URL="https://bbs.archlinux.org/"
+-BUG_REPORT_URL="https://bugs.archlinux.org/"
++HOME_URL="https://www.archlinux32.org/"
++SUPPORT_URL="https://bbs.archlinux32.org/"
++BUG_REPORT_URL="https://bugs.archlinux32.org/"