summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2021-07-29 14:57:22 +0200
committerAndreas Baumann <mail@andreasbaumann.cc>2021-07-29 14:57:22 +0200
commit0279e377cfdb25a166039ef3b81c933d2a3a7201 (patch)
tree5865b1c745ef03b87646caccab239a10f39dec8d
parentbf063d41a6580a22970f6ceb7ade36355c6c20d5 (diff)
downloadpackages-0279e377cfdb25a166039ef3b81c933d2a3a7201.tar.xz
community/linux-tools: disabled fetching source tarball from archive-server, gettig an empty tarball, building from git
-rw-r--r--community/linux-tools/PKGBUILD114
1 files changed, 57 insertions, 57 deletions
diff --git a/community/linux-tools/PKGBUILD b/community/linux-tools/PKGBUILD
index 9a71c096..954128ec 100644
--- a/community/linux-tools/PKGBUILD
+++ b/community/linux-tools/PKGBUILD
@@ -1,58 +1,58 @@
# use our tarballer instead of cloning from git
-for ((i=0; i<${#source[@]}; i++)); do
- infos=$(
- printf '%s\n' "${source[${i}]}" | \
- sed -n '
- s@^\(\([^:]\+\)::\)\?\(git\|hg\)+\([^#?]\+\)\(?signed\)\?#\(\(tag\|commit\)=\S\+\)$@\3 \2 \4 \5 \6@
- T
- p
- '
- )
- if [ -n "${infos}" ]; then
- source[${i}]=$(
- type="${infos%% *}"
- infos="${infos#* }"
- if [ -n "${infos%% *}" ]; then
- prefix="${infos%% *}"
- else
- prefix=''
- fi
- infos="${infos#* }"
- repo="${infos%% *}"
- repo64=$(
- printf '%s' "${repo}" | \
- base64 -w0 | \
- sed 's/=/%3D/g'
- )
- infos="${infos#* }"
- if [ "${infos%% *}" = '?signed' ]; then
- key_check=$(
- printf '&valid_keys='
- printf '%s,' "${validpgpkeys[@]}" | \
- sed 's/,$//'
- )
- else
- key_check=''
- fi
- infos="${infos#* }"
- if [ -z "${prefix}" ]; then
- prefix="${repo%.git}"
- prefix="${prefix##*/}"
- fi
- prefix_64=$(
- printf '%s/' "${prefix}" | \
- base64 -w0 | \
- sed 's/=/%3D/g'
- )
-
- printf '%s-%s.tar.gz::https://archive-server.archlinux32.org/?t=%s&p=%s&r=%s%s&%s\n' \
- "${prefix}" \
- "${pkgver}" \
- "${type}" \
- "${prefix_64}" \
- "${repo64}" \
- "${key_check}" \
- "${infos}"
- )
- fi
-done
+#for ((i=0; i<${#source[@]}; i++)); do
+# infos=$(
+# printf '%s\n' "${source[${i}]}" | \
+# sed -n '
+# s@^\(\([^:]\+\)::\)\?\(git\|hg\)+\([^#?]\+\)\(?signed\)\?#\(\(tag\|commit\)=\S\+\)$@\3 \2 \4 \5 \6@
+# T
+# p
+# '
+# )
+# if [ -n "${infos}" ]; then
+# source[${i}]=$(
+# type="${infos%% *}"
+# infos="${infos#* }"
+# if [ -n "${infos%% *}" ]; then
+# prefix="${infos%% *}"
+# else
+# prefix=''
+# fi
+# infos="${infos#* }"
+# repo="${infos%% *}"
+# repo64=$(
+# printf '%s' "${repo}" | \
+# base64 -w0 | \
+# sed 's/=/%3D/g'
+# )
+# infos="${infos#* }"
+# if [ "${infos%% *}" = '?signed' ]; then
+# key_check=$(
+# printf '&valid_keys='
+# printf '%s,' "${validpgpkeys[@]}" | \
+# sed 's/,$//'
+# )
+# else
+# key_check=''
+# fi
+# infos="${infos#* }"
+# if [ -z "${prefix}" ]; then
+# prefix="${repo%.git}"
+# prefix="${prefix##*/}"
+# fi
+# prefix_64=$(
+# printf '%s/' "${prefix}" | \
+# base64 -w0 | \
+# sed 's/=/%3D/g'
+# )
+#
+# printf '%s-%s.tar.gz::https://archive-server.archlinux32.org/?t=%s&p=%s&r=%s%s&%s\n' \
+# "${prefix}" \
+# "${pkgver}" \
+# "${type}" \
+# "${prefix_64}" \
+# "${repo64}" \
+# "${key_check}" \
+# "${infos}"
+# )
+# fi
+#done