summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Baumann <mail@andreasbaumann.cc>2017-12-29 20:16:41 +0100
committerAndreas Baumann <mail@andreasbaumann.cc>2017-12-29 20:16:41 +0100
commit08d84088dd2e9dcdf3fdfc1703d64c3ac3259b7b (patch)
tree5a0b3ceec14676f91ee1661b562f71ea501e47d4
parent9ac64237f1455fbcec5a358d6e637969f1c10562 (diff)
downloadpackages-08d84088dd2e9dcdf3fdfc1703d64c3ac3259b7b.tar.xz
extra/texmacs: more sed-fu to fix compilation
-rw-r--r--extra/texmacs/PKGBUILD6
1 files changed, 3 insertions, 3 deletions
diff --git a/extra/texmacs/PKGBUILD b/extra/texmacs/PKGBUILD
index 6469e015..0c02dc63 100644
--- a/extra/texmacs/PKGBUILD
+++ b/extra/texmacs/PKGBUILD
@@ -1,10 +1,10 @@
# guile cmake checks allow int* to be casted to size_t*, so we
-# add -fpermissive to make the int cast fail and the size_t cast
-# succeed
+# add force guile_str_size_t to size_t after the test (no matter
+# what the outcome is)
eval "$(
declare -f prepare | \
sed '
- /cd TeXmacs-${pkgver}-src/ a \ sed -i "/SET(CMAKE_REQUIRED_FLAGS/s/-Werror /-Werror -fpermissive /" CMakeLists.txt
+ /cd TeXmacs-${pkgver}-src/ a \ sed -i "/ENDIF(_guile_str_size_test)/ a \ SET(guile_str_size_t size_t)" CMakeLists.txt
'
)"