summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorErich Eckner <git@eckner.net>2019-01-21 10:10:08 +0100
committerErich Eckner <git@eckner.net>2019-01-21 10:10:08 +0100
commit826946fc5850f99f21151d575e3d01c2180c8881 (patch)
tree57952daf8f036922a378ddf251fba244283cf15e
parentb1ef18278ba295fcddd30751d8294e76e638724e (diff)
parent500ec8d4e6dc3f4ee834c1dd9f4dc5bc43e37196 (diff)
downloadpackages-826946fc5850f99f21151d575e3d01c2180c8881.tar.xz
Merge branch 'master' into i486
-rw-r--r--community/exa/PKGBUILD9
-rw-r--r--community/exa/exa-ascii-deprecated.patch12
-rw-r--r--community/openscenegraph34/PKGBUILD6
-rw-r--r--core/linux/PKGBUILD8
-rw-r--r--core/linux/config.i4864
-rw-r--r--core/linux/config.i6864
-rw-r--r--extra/flashplugin/PKGBUILD4
-rw-r--r--extra/linux-pae/PKGBUILD6
-rw-r--r--extra/linux-pae/config5
-rw-r--r--extra/linux-zen/PKGBUILD6
-rw-r--r--extra/linux-zen/config8
-rw-r--r--extra/llvm/PKGBUILD19
12 files changed, 50 insertions, 41 deletions
diff --git a/community/exa/PKGBUILD b/community/exa/PKGBUILD
new file mode 100644
index 00000000..1de368f8
--- /dev/null
+++ b/community/exa/PKGBUILD
@@ -0,0 +1,9 @@
+# fixed in git upstream
+
+source+=('exa-ascii-deprecated.patch')
+md5sums+=('ce36630a183f5d5be9f1a334bdf8a7cc')
+
+prepare() {
+ cd "$pkgname"
+ patch -Np1 -i ../exa-ascii-deprecated.patch
+}
diff --git a/community/exa/exa-ascii-deprecated.patch b/community/exa/exa-ascii-deprecated.patch
new file mode 100644
index 00000000..e4cddd6a
--- /dev/null
+++ b/community/exa/exa-ascii-deprecated.patch
@@ -0,0 +1,12 @@
+diff -rauN exa/src/fs/file.rs exa-ascii-deprecated-patch/src/fs/file.rs
+--- exa/src/fs/file.rs 2018-12-09 12:48:21.137587385 +0100
++++ exa-ascii-deprecated-patch/src/fs/file.rs 2018-12-09 12:59:07.048431583 +0100
+@@ -95,8 +95,6 @@
+ /// against a pre-compiled list of extensions which are known to only exist
+ /// within ASCII, so it’s alright.
+ fn ext(path: &Path) -> Option<String> {
+- use std::ascii::AsciiExt;
+-
+ let name = match path.file_name() {
+ Some(f) => f.to_string_lossy().to_string(),
+ None => return None,
diff --git a/community/openscenegraph34/PKGBUILD b/community/openscenegraph34/PKGBUILD
new file mode 100644
index 00000000..78dcdca7
--- /dev/null
+++ b/community/openscenegraph34/PKGBUILD
@@ -0,0 +1,6 @@
+eval "$(
+ declare -f package | \
+ sed '
+ s@mv "${pkgdir}/usr/lib64" "${pkgdir}/usr/lib"@#\0@
+ '
+)"
diff --git a/core/linux/PKGBUILD b/core/linux/PKGBUILD
index f0b8eb50..da3f2a9e 100644
--- a/core/linux/PKGBUILD
+++ b/core/linux/PKGBUILD
@@ -1,12 +1,12 @@
-# upstream git revision: 2e669a90e89f01c68b7b0faf7f6084aabca61c3f
+# upstream git revision: 32c7bb2ff85bb14365f4f0178f57dbd4d7cdc44d
source_i686=('config.i686')
source_i486=('config.i486')
# fail if upstream's .config changes
for ((i=0; i<${#sha256sums[@]}; i++)); do
- if [ "${sha256sums[${i}]}" = 'e7fa30bb2de12d1a2488423e27c00f26d55668e310e69aaf93673c1afd89dbaf' ]; then
- sha256sums_i686=('4af6c8a227ff11512fc11c8654d8148224caef9fcfd26f7927a319abb38a18e9')
- sha256sums_i486=('3ef8623d68b0615003e0603b63cc6f74c4904926c5b920155d6cd06650cb3c8c')
+ if [ "${sha256sums[${i}]}" = 'beb5d9b4280490bec595ef43acb6a9084d579e10fe8329f9a779f6358d887ed1' ]; then
+ sha256sums_i686=('cffa10b61e52cd1c8747dbf8a7297f91a624174330adfb88a17e4de204db5935')
+ sha256sums_i486=('f30e5dc00e43b5cffc8e7ce8c502d064d92ffd71a7163710cc7241548b022307')
fi
done
diff --git a/core/linux/config.i486 b/core/linux/config.i486
index ab8bc501..fb9f0821 100644
--- a/core/linux/config.i486
+++ b/core/linux/config.i486
@@ -1,10 +1,10 @@
#
# Automatically generated file; DO NOT EDIT.
-# Linux/x86 4.19.4-arch1 Kernel Configuration
+# Linux/x86 4.19.8-arch1 Kernel Configuration
#
#
-# Compiler: gcc (GCC) 8.2.1 20180831
+# Compiler: gcc (GCC) 8.2.1 20181127
#
CONFIG_CC_IS_GCC=y
CONFIG_GCC_VERSION=80201
diff --git a/core/linux/config.i686 b/core/linux/config.i686
index 950853bd..025cd7c7 100644
--- a/core/linux/config.i686
+++ b/core/linux/config.i686
@@ -1,10 +1,10 @@
#
# Automatically generated file; DO NOT EDIT.
-# Linux/x86 4.19.4-arch1 Kernel Configuration
+# Linux/x86 4.19.8-arch1 Kernel Configuration
#
#
-# Compiler: gcc (GCC) 8.2.1 20180831
+# Compiler: gcc (GCC) 8.2.1 20181127
#
CONFIG_CC_IS_GCC=y
CONFIG_GCC_VERSION=80201
diff --git a/extra/flashplugin/PKGBUILD b/extra/flashplugin/PKGBUILD
index cbb15f89..318302f7 100644
--- a/extra/flashplugin/PKGBUILD
+++ b/extra/flashplugin/PKGBUILD
@@ -1,4 +1,4 @@
# bring back the i686 specific stuff
source=("${source[@]//x86_64/i386}")
-sha256sums=('478cf3011bcb0eebc87b08a718f07ca4aeff48f1ce5b15615da452df8793bb6b'
- '09b34a98ea8828e1ebef3572e47d51bacd98dfc24c153d69346f54d48aa1f8cb')
+sha256sums=('fa328e6f68a56522e7e5f3e47fc299796cbf3532a26885ff545a6b6aad6eb5ea'
+ '923706a7f0558b19e1f33aa20c3b0de2af34bfdf41398b14577362c94718e6a9')
diff --git a/extra/linux-pae/PKGBUILD b/extra/linux-pae/PKGBUILD
index a0f1cfa8..90c6c2ad 100644
--- a/extra/linux-pae/PKGBUILD
+++ b/extra/linux-pae/PKGBUILD
@@ -4,7 +4,7 @@
# Maintainer: Thomas Baechler <thomas@archlinux.org>
pkgbase=linux-pae # Build stock -ARCH kernel
-pkgver='4.19.6'
+pkgver='4.19.9'
_srcname=linux-${pkgver}
pkgrel='1'
arch=('i686')
@@ -24,9 +24,9 @@ validpgpkeys=(
'ABAF11C65A2970B130ABE3C479BE3E4300411886' # Linus Torvalds
'647F28654894E3BD457199BE38DBBDC86092693E' # Greg Kroah-Hartman
)
-sha256sums=('644e61beb66211c0c5c13f91d96de1725055e6eea4cda7bb37ce9929ba8f09c3'
+sha256sums=('fc116cc6829c73944215d3b3ac0fc368dde9e8235b456744afffde001269dbf2'
'SKIP'
- 'd5581f427d5e9846161f1224b0bf04c22c3c5dac6c8b6bff99f1230cab68d3c5'
+ 'b1f72da663020ab122aa757033b2b7766a0bedc360a148cadea0c2b15530f08c'
'ae2e95db94ef7176207c690224169594d49445e04249d2499e9d2fbc117a0b21'
'75f99f5239e03238f88d1a834c50043ec32b1dc568f2cc291b07d04718483919'
'ad6344badc91ad0630caacde83f7f9b97276f80d26a20619a87952be65492c65'
diff --git a/extra/linux-pae/config b/extra/linux-pae/config
index b086737f..371470e9 100644
--- a/extra/linux-pae/config
+++ b/extra/linux-pae/config
@@ -1,10 +1,10 @@
#
# Automatically generated file; DO NOT EDIT.
-# Linux/x86 4.19.6-1 Kernel Configuration
+# Linux/x86 4.19.9-1 Kernel Configuration
#
#
-# Compiler: gcc (GCC) 8.2.1 20180831
+# Compiler: gcc (GCC) 8.2.1 20181127
#
CONFIG_CC_IS_GCC=y
CONFIG_GCC_VERSION=80201
@@ -3416,6 +3416,7 @@ CONFIG_MWL8K=m
CONFIG_WLAN_VENDOR_MEDIATEK=y
CONFIG_MT7601U=m
CONFIG_MT76_CORE=m
+CONFIG_MT76_LEDS=y
CONFIG_MT76_USB=m
CONFIG_MT76x2_COMMON=m
CONFIG_MT76x0U=m
diff --git a/extra/linux-zen/PKGBUILD b/extra/linux-zen/PKGBUILD
index c725625d..51e6a6ab 100644
--- a/extra/linux-zen/PKGBUILD
+++ b/extra/linux-zen/PKGBUILD
@@ -1,9 +1,9 @@
-# upstream git revision: 2e669a90e89f01c68b7b0faf7f6084aabca61c3f
+# upstream git revision: 32c7bb2ff85bb14365f4f0178f57dbd4d7cdc44d
# fail if upstream's .config changes
for ((i=0; i<${#sha256sums[@]}; i++)); do
- if [ "${sha256sums[${i}]}" = '4e4da53c86f21f5949519c57884d322a486107ea1559a5ff9f2318c08cafcdf1' ]; then
- sha256sums[${i}]='42961d0de8c847b7958f8b8ea49278c22edb4887d24d1f90e88008ac65102fcb'
+ if [ "${sha256sums[${i}]}" = '17fe21a4c8507064675bd30c9266c22415fe4118d57161239e27e04ae96e2378' ]; then
+ sha256sums[${i}]='d2e12d879c9956a12bcae7a4d0b02efb3a3e712cca3f442a5a8a81d71581567e'
fi
done
diff --git a/extra/linux-zen/config b/extra/linux-zen/config
index 3f21f6e7..905c6a95 100644
--- a/extra/linux-zen/config
+++ b/extra/linux-zen/config
@@ -1,10 +1,10 @@
#
# Automatically generated file; DO NOT EDIT.
-# Linux/x86 4.19.4-zen1 Kernel Configuration
+# Linux/x86 4.19.8-zen2 Kernel Configuration
#
#
-# Compiler: gcc (GCC) 8.2.1 20180831
+# Compiler: gcc (GCC) 8.2.1 20181127
#
CONFIG_CC_IS_GCC=y
CONFIG_GCC_VERSION=80201
@@ -1043,8 +1043,8 @@ CONFIG_ARCH_SUPPORTS_MEMORY_FAILURE=y
CONFIG_MEMORY_FAILURE=y
CONFIG_HWPOISON_INJECT=m
CONFIG_TRANSPARENT_HUGEPAGE=y
-# CONFIG_TRANSPARENT_HUGEPAGE_ALWAYS is not set
-CONFIG_TRANSPARENT_HUGEPAGE_MADVISE=y
+CONFIG_TRANSPARENT_HUGEPAGE_ALWAYS=y
+# CONFIG_TRANSPARENT_HUGEPAGE_MADVISE is not set
CONFIG_TRANSPARENT_HUGE_PAGECACHE=y
CONFIG_CLEANCACHE=y
CONFIG_FRONTSWAP=y
diff --git a/extra/llvm/PKGBUILD b/extra/llvm/PKGBUILD
deleted file mode 100644
index 4aaafe29..00000000
--- a/extra/llvm/PKGBUILD
+++ /dev/null
@@ -1,19 +0,0 @@
-# temporary, ocaml is broken on 32-bit, we work around the llvm issue
-# in binutils LTO plugins for now:
-makedepends=(${makedepends[@]/ocaml=$_ocaml_ver/})
-makedepends=(${makedepends[@]/ocaml-ctypes/})
-makedepends=(${makedepends[@]/ocaml-findlib/})
-
-eval "$(
- declare -f build | \
- sed '
- s/ninja all ocaml_doc/ninja all/
- '
-)"
-
-eval "$(
- declare -f package_llvm | \
- sed '
- /ocaml/d
- '
-)"